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UNIT- I 

INTRODUCTION OF COMPUTER GRAPHICS 

Computer Graphics involves technology to access. The Process transforms 

and presents information in a visual form. The role of computer graphics insensible. In 

today life, computer graphics has now become a common element in user interfaces, 

T.V. commercial motion pictures. 

Computer Graphics is the creation of pictures with the help of a computer. 

The end product of the computer graphics is a picture it may be a business graph, 

drawing, and engineering. 

In computer graphics, two or three-dimensional pictures can be created that 

are used for research. Many hardware devices algorithm has been developing for 

improving the speed of picture generation with the passes of time. It includes the 

creation storage of models and image of objects. These models for various fields like 

engineering, mathematical and so on. 

Today computer graphics is entirely different from the earlier one. It is not 

possible. It is an interactive user can control the structure of an object of various input 

devices. 

DEFINITION OF COMPUTER GRAPHICS: 

Computer graphics is an art of drawing pictures, lines, charts, etc using computers 

with the help of programming. Computer graphics is made up of number of pixels. Pixel 

is the smallest graphical picture or unit represented on the computer screen. Basically 

there are two types of computer graphics namely. 

 Interactive Computer Graphics. 

 Non Interactive Computer Graphics. 

Interactive Computer Graphics: Interactive Computer Graphics involves a two way 

communication between computer and user. Here the observer is given some control 

over the image by providing him with an input device for example the video game 

controller of the ping pong game. This helps him to signal his request to the computer. 
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The computer on receiving signals from the input device can modify the 

displayed picture appropriately. To the user it appears that the picture is changing 

instantaneously in response to his commands. He can give a series of commands, each 

one generating a graphical response from the computer. In this way he maintains a 

conversation, or dialogue, with the computer. 

Interactive computer graphics affects our lives in a number of indirect ways. 

For example, it helps to train the pilots of our airplanes. We can create a flight simulator 

which may help the pilots to get trained not in a real aircraft but on the grounds at the 

control of the flight simulator. The flight simulator is a mockup of an aircraft flight deck, 

containing all the usual controls and surrounded by screens on which we have the 

projected computer generated views of the terrain visible on takeoff and landing. 

Flight simulators have many advantages over the real aircrafts for training 

purposes, including fuel savings, safety, and the ability to familiarize the trainee with a 

large number of the world’s airports. 

Non Interactive Computer Graphics: In non-interactive computer graphics otherwise 

known as passive computer graphics. It is the computer graphics in which user does 

not have any kind of control over the image. Image is merely the product of static 

stored program and will work according to the instructions given in the program 

linearly. The image is totally under the control of program instructions not under the 

user. Example: screen savers. 

DIFFERENCE BETWEEN AN INPUT AND OUTPUT DEVICE 

An input device sends information to a computer system for processing, and 

an output device reproduces or displays the results of that processing. Input devices 

only allow for input of data to a computer and output devices only receive the output 

of data from another device. 

Most devices are only input devices or output devices, as they can only 

accept data input from a user or output data generated by a computer. However, some 

devices can accept input and display output, and they are referred to as I/O devices 

(input/output devices). 
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For example, as you can see in the top half of the image, a keyboard sends 

electrical signals, which are received by the computer as input. Those signals are then 

interpreted by the computer and displayed, or output, on the monitor as text or 

images. In the lower half of the image, the computer sends, or outputs, data to a 

printer, which will print the data onto a piece of paper, also considered output. 

 

INPUT DEVICES 

An input device can send data to another device, but it cannot receive data from 

another device. Examples of input devices include the following. 

 Keyboard and Mouse - Accepts input from a user and sends that data (input) to 

the computer. They cannot accept or reproduce information (output) from the 

computer. 

 Microphone - Receives sound generated by an input source, and sends that 

sound to a computer. 

 Webcam - Receives images generated by whatever it is pointed at (input) and 

sends those images to a computer. 

The most commonly used or primary input devices on a computer are the keyboard 

and mouse. However, there are dozens of other devices that can also be used to input 

data into the computer. 

TYPES OF INPUT DEVICES 

 Audio conversion device 

 Barcode reader 

 Biometrics (e.g., fingerprint scanner). 

 Business card reader 

 Digital camera and digital camcorder. 

 EEG (electroencephalography) 

 Finger (with touch screen or Windows Touch). 

 Gamepad, joystick, paddle, steering wheel, and Microsoft Kinect. 

 Gesture recognition 

 Graphics tablet 
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 Keyboard 

 Light gun 

 Light pen 

 Magnetic ink (like the ink found on checks). 

 Magnetic stripe reader 

 Medical imaging devices (e.g., X-ray, CAT scan, and ultrasound images). 

 Microphone (using voice speech recognition or biometric verification). 

 MIDI keyboard 

 MICR 

 Mouse, touchpad, or other pointing devices. 

 OMR (optical mark reader) 

 Paddle 

 Pen or stylus 

 Punch card reader 

 Remote 

 Scanner 

 Sensors (e.g., heat and orientation sensors). 

 Sonar imaging devices 

 Stylus (with touch screen). 

 Touch screen 

 Voice (using voice speech recognition or biometric verification). 

 Video capture device 

 VR helmet and gloves 

 Webcam 

 Yoke 

OUTPUT DEVICES 

An output device can receive data from another device and generate output with 

that data, but it cannot send data to another device. Examples of output devices 

include the following. 
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 Monitor - Receives data from a computer (output) and displays that information 

as text and images for users to view. It cannot accept data from a user and send 

that data to another device. 

 Projector - Receives data from a computer (output) and displays, or projects, 

that information as text and images onto a surface, like a wall or a screen. It 

cannot accept data from a user and send that data to another device. 

 Speakers - Receives sound data from a computer and plays the sounds for users 

to hear. It cannot accept sound generated by users and send that sound to 

another device. 

Types of output devices 

The following list contains many different examples of output devices. For further 

information about the output device, select any of the listings with blue text. 

 3D Printer 

 Braille embosser 

 Braille reader 

 COM (Computer Output Microfilm) 

 Flat-panel 

 GPS 

 Headphones 

 Monitor 

 Plotter 

 Printer (dot matrix printer, inkjet printer, and laser printer) 

 Projector 

 Sound card 

 Speakers 

 SGD (Speech-generating device) 

 TV 

 Video card 
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Input/output devices 

An input/output device can receive data from users, or another device (input), 

and send data to another device (output). Examples of input/output devices include 

the following. 

 CD-RW drive and DVD-RW drive - Receives data from a computer (input), to 

copy onto a writable CD or DVD. Also, the drive sends data contained on a 

CD or DVD (output) to a computer. 

 USB flash drive - Receives, or saves, data from a computer (input). Also, the 

drive sends data to a computer or another device (output). 

NOTE: Drives such as a CD-ROM, DVD, floppy diskette drive, and USB flash drive are 

considered storage devices. 

RANDOM SCAN AND RASTER SCAN DISPLAY 

RANDOM SCAN DISPLAY: 

Random Scan System uses an electron beam which operates like a pencil to create a 

line image on the CRT screen. The picture is constructed out of a sequence of straight-

line segments. Each line segment is drawn on the screen by directing the beam to 

move from one point on the screen to the next, where its x & y coordinates define 

each point. After drawing the picture. The system cycles back to the first line and 

design all the lines of the image 30 to 60 time each second. The process is shown in 

fig: 
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Random-scan monitors are also known as vector displays or stroke-writing displays or 

calligraphic displays. 

Advantages: 

1. A CRT has the electron beam directed only to the parts of the screen where 

an image is to be drawn. 

2. Produce smooth line drawings. 

3. High Resolution 

Disadvantages: 

1. Random-Scan monitors cannot display realistic shades scenes. 

 

 

RASTER SCAN DISPLAY: 

A Raster Scan Display is based on intensity control of pixels in the form of a rectangular 
box called Raster on the screen. Information of on and off pixels is stored in refresh 
buffer or Frame buffer. Televisions in our house are based on Raster Scan Method. The 
raster scan system can store information of each pixel position, so it is suitable for 
realistic display of objects. Raster Scan provides a refresh rate of 60 to 80 frames per 
second. 

Frame Buffer is also known as Raster or bit map. In Frame Buffer the positions are 
called picture elements or pixels. Beam refreshing is of two types. First is horizontal 
retracing and second is vertical retracing. When the beam starts from the top left 
corner and reaches the bottom right scale, it will again return to the top left side called 
at vertical retrace. Then it will again more horizontally from top to bottom call as 
horizontal retracing shown in fig: 
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Types of Scanning or travelling of beam in Raster Scan 

1. Interlaced Scanning 

2. Non-Interlaced Scanning 

In Interlaced scanning, each horizontal line of the screen is traced from top to bottom. 

Due to which fading of display of object may occur. This problem can be solved by 

Non-Interlaced scanning. In this first of all odd numbered lines are traced or visited 

by an electron beam, then in the next circle, even number of lines are located. 

For non-interlaced display refresh rate of 30 frames per second used. But it gives 

flickers. For interlaced display refresh rate of 60 frames per second is used. 

Advantages: 

1. Realistic image 

2. Million Different colors to be generated 

3. Shadow Scenes are possible. 

Disadvantages: 

1. Low Resolution 

2. Expensive 

 

Differentiate between Random and Raster Scan Display: 

RANDOM SCAN RASTER SCAN 
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1. It has high Resolution 1. Its resolution is low. 

2. It is more expensive 2. It is less expensive 

3. Any modification if needed is easy 3.Modification is tough 

4. Solid pattern is tough to fill 4.Solid pattern is easy to fill 

5. Refresh rate depends or resolution 5. Refresh rate does not depend on the picture. 

6. Only screen with view on an area is 

displayed. 

6. Whole screen is scanned. 

7. Beam Penetration technology come under it. 7. Shadow mark technology came under this. 

8. It does not use interlacing method. 8. It uses interlacing 

9. It is restricted to line drawing applications 9. It is suitable for realistic display. 

 

 

DDA and Bresenham‟s Line Drawing Algorithms 

Definition of DDA Algorithm 

A DDA (Digital Differential Analyzer) algorithms is a scan-conversion method 

for drawing a line which follows an incremental approach. In this algorithm to draw a 

line the difference in the pixel points is analyzed then according to that the line is 

drawn. The method is said to be incremental because it performs computations at 

each step and uses the outcome of the previous step. 

Before understanding DDA algorithm, we must understand what a line is and how it 

is defined? When two points in a plane connected by a line segment and falls under 

the line equation is known as a line. The line equation mentioned above is y=mx+b 

where m is the slope (i.e., m = Δy/Δx) and y is the intercept of the line (the value of y 

at the points of the line). 
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Now for DDA, let us assume at i we have computed (xi, yi) to be a point on the line as 

the next point (xi+1, yi+1) should Δy/Δx = m where Δy = (yi+1) – yi and Δx = (xi+1) – xi, 

which gives, 

yi+1 = yi + mΔx or xi+1 = xi + Δy/m 

Depending on the slope three types of situations can arise shown in the below-given 

diagram: 

 

It does not use the floating point multiplication. However, it uses the floating point 

addition which makes it faster than the straight implementation of the line equation. 

The algorithm is not precise because of the usage of floating point representation 

could cause computed points to drift away from their actual position when the line is 

relatively long. 
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Definition of Bresenham”s Algorithm 

Bresenham”s algorithm also provides an efficient raster scan method for 

generating lines where incremental integer calculations are used. The developer of the 

algorithm was Jack Elton Bresenham”s, and the algorithm was named after him. It 

generates mathematically precise results with the help of addition, subtraction and 

multiplication by 2, which can be achieved by a simple arithmetic shift operation. 

 

The above-given diagram explains the illustration of the straight line drawn over a 

display screen. Here the vertical axes indicate scan line positions, and the horizontal 

axes signify pixel columns. In the sampling at unit x intervals (as shown in example), 

we need to figure out which possible pixel positions lie nearer to the line path at each 

consequent step. So, this algorithm does it by examining the sign of an integer 

parameter, where its value is equal to the difference between the separations of the 

two pixel position from the true line path. 

Now let’s understand Bresenham”s approach, considering a scan-conversion 

technique for lines having a positive slope of less than 1. Then the pixel location over 

the line path are then calculated by sampling at unit x intervals. It begins from the left 

endpoint (x0, y0) of a provided line, then each consecutive column (x position) is 

considered, and pixels are plotted where the scan-line y value is nearest to the line 

path. Suppose we have deduced that the pixel to be displayed at (xk, yk), then the next 

decision to ponder about is which pixel to plot in column xk+1. We can select for the 

pixels at the given positions (xk+1, yk) and (xk+1, yk+1). 
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For the position xk+1, the vertical line path labelled as d1 and d2 from the 

mathematical line path. The y coordinate for pixel column position xk+1 is 

deduced as 

y = m (xk+1) + b – Eq 1 

Then 

d1 = y-yk = m (xk+1) + b – yk 

and 

d2 = (yk+1) – y = yk+1 + m (xk+1) – b 

The difference between these two separations is 

d1-d2 = 2m (xk+1) – 2yk +2b -1  – Eq 2 

The decision parameter Pk for the kth iteration in the line algorithm is obtained by 

reordering 2nd equation and substituting Δy/Δx in place of m. Δy and Δx are the 

vertical and horizontal separation of the endpoints position. 

Pk = Δ x (d1 – d2) = 2 Δy . xk – 2 Δx . yk + c        –Eq 3 

Here the sign of Pk is equal to the d1-d2 as Δx is greater than 0. The value of the 

parameter c (constant) is 2Δy + Δx(2b-1) which does not affect the pixel position 

and can be removed in the recursive calculation of Pk. In some other cases, the 

pixel at yk position could present near to the line path than a pixel at yk+1 (i.e., 

d1>d2) and the parameter Pk is negative. In that condition, we plot the lower pixel. 

Otherwise, the upper pixel is plotted. 
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Integrated changes along the line occur in unit steps in any of the direction x or y. 

Therefore, the consequent decision parameters are calculated using an 

incremental approach. At k+1 iteration, the decision parameter is calculated from 

equation 3. 

Pk+1 = 2Δy . xk+1  –  2 Δx.yk+1 + c 

Subtracting equation 3 from the above equation, we get 

Pk+1 – Pk = 2 Δy (xk+1-xk) – 2Δx(yk+1 – y) 

but xk+1 = xk+1, so that 

Pk+1 = Pk + 2 Δy – 2 Δx (yk+1 – yk) 

The term yk+1 – yk is either 0 or 1, according to the sign of parameter Pk. This 

iterative calculation of decision parameters is carried out at every integer x 

position, beginning from the left coordinate endpoint of the line. The first 

parameter P0 is calculated from equation 3 at the pixel position (x0,y0) and m 

substituted as Δy/Δx. 

P0  =  2 Δy – Δx 

Key Differences between DDA and Bresenham”s line drawing algorithm 

 Bresenham”s algorithm is more efficient and accurate than DDA algorithm. 

 The DDA algorithm involves floating point values while in Bresenham”s 

algorithm only integer values is included. This is the major reason that made 

the computations in DDA difficult than the Bresenham”s algorithm. 

 DDA uses multiplication and division operations. As against, Bresenham”s 

involves addition and subtraction causing less consumption of time. 

Therefore, DDA is slower than Bresenham”s. 

 The values in DDA never rounded off. In contrast, Bresenham”s rounds off 

the value to the closest integer value. 

 Bresenham”s algorithm is optimized. Conversely, DDA is not and less 

expensive. 
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Conclusion 

The Bresenham”s line drawing algorithm is more efficient and better in all aspects 

than the DDA algorithm which is not that efficient. 

 

BRESENHAM‟S AND MID-POINT CIRCLE DRAWING ALGORITHMS 

It is not easy to display a continuous smooth arc on the computer screen as our 

computer screen is made of pixels organized in matrix form. So, to draw a circle on 

a computer screen we should always choose the nearest pixels from a printed pixel 

so as they could form an arc. There are two algorithm to do this: 

1. Mid-Point circle drawing algorithm 

2. Bresenham”s circle drawing algorithm 

1- Mid-Point Circle Drawing Algorithm 

We need to plot the perimeter points of a circle whose center co-ordinates 

and radius are given using the Mid-Point Circle Drawing Algorithm. 

We use the above algorithm to calculate all the perimeter points of the circle 

in the first octant and then print them along with their mirror points in the other 

octants. This will work only because a circle is symmetric about its center. 

 

The algorithm is very similar to the Mid-Point Line Generation Algorithm. 

Here, only the boundary condition is different. 

For any given pixel (x, y), the next pixel to be plotted is either (x, y+1) or (x-

1, y+1). This can be decided by following the steps below. 
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Find the mid-point p of the two possible pixels i.e (x-0.5, y+1) 

If p lies inside or on the circle perimeter, we plot the pixel (x, y+1), otherwise if it’s 

outside we plot the pixel (x-1, y+1) 

 

2- Bresenham”s circle drawing algorithm 

Mid-Point circle drawing algorithm and Bresenham”s circle drawing algorithm. 

Both of these algorithms uses the key feature of circle that it is highly symmetric. 

So, for whole 360 degree of circle we will divide it in 8-parts each octant of 45 

degree. In order to that we will use Bresenham”s Circle Algorithm for calculation of 

the locations of the pixels in the first octant of 45 degrees. It assumes that the circle 

is centered on the origin. So for every pixel (x, y) it calculates, we draw a pixel in 

each of the 8 octants of the circle as shown below: 

 

Now, we will see how to calculate the next pixel location from a previously known pixel 

location (x, y). In Bresenham’s algorithm at any point (x, y) we have two option either 

to choose the next pixel in the east i.e. (x+1, y) or in the south east i.e. (x+1, y-1). 
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And this can be decided by using the decision parameter d as: 

 If d > 0, then (x+1, y-1) is to be chosen as the next pixel as it will be closer to 
the arc. 

 else (x+1, y) is to be chosen as next pixel. 
Now to draw the circle for a given radius ‘r’ and centre (xc, yc) We will start from 
(0, r) and move in first quadrant till x=y (i.e. 45 degree). We should start from listed 
initial condition: 

d = 3 - (2 * r) 

x = 0 

y = r 

Now for each pixel, we will do the following operations: 

1. Set initial values of (xc, yc) and (x, y) 
2. Set decision parameter d to d = 3 – (2 * r). 
3. call drawCircle(int xc, int yc, int x, int y) function. 
4. Repeat steps 5 to 8 until x < = y 
5. Increment value of x. 
6. If d < 0, set d = d + (4*x) + 6 
7. Else, set d = d + 4 * (x – y) + 10 and decrement y by 1. 
8. call drawCircle(int xc, int yc, int x, int y) function 

 

 



DEPARTMENT OF COMPUTER SCIENCE 
 

 

BCA-402 
Computer Graphics & Packages 

 

P
ag

e1
7

 

HOMOGENEOUS COORDINATE SYSTEM FOR 2D AND 3D 

Homogeneous coordinates A coordinate system that algebraically treats all 

points in the projective plane (both Euclidean and ideal) equally. For example, the 

standard homogeneous coordinates [p1,p2,p3] of a point P in the projective plane are 

of the form [x,y,1] if P is a point in the Euclidean plane z=1 whose Cartesian coordinates 

are (x,y,1), or are of the form [a,b,0] if P is the ideal point – the point at infinity – 

associated to all lines in the Euclidean plane z=1 with direction numbers a,b,0. 

Homogeneous coordinates are so called because they treat Euclidean and ideal points 

in the same way. 

Homogeneous coordinates are widely used in computer graphics because they enable 

affine and projective transformations to be described as matrix manipulations in a 

coherent way. 

The sequence of transformation like as translation followed by rotation and scaling, 

the process followed is as follows: 

 The coordinates are translated 
 The translated coordinates are rotated 
 The rotated coordinates are scaled for completing the composite 

transformation. 

This process is shortened by using 3×3 transformation matrix instead of 2×2 

transformation matrix. The 2x2 matrix is converted into 3x3 matrix by adding the extra 

dummy coordinate 

The point is represented by 3 numbers instead of 2 numbers known as Homogenous 

Coordinate system. All the transformation equations in the matrix multiplication can 

be represented in this system. Any Cartesian point P(X, Y) can be converted to 

homogenous coordinates by P’ (Xh, Yh, h). 

2D TRANSFORMATION 

Some graphics are changed into something else by applying some of the 

rules, known as Transformation. Various types of transformation are there such as 

translation, scaling up or down, rotation, shearing, etc. This transformation when 

takes place in 2D plane, is known as 2D transformation. In order to reposition the 
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graphics on the screen and change the size or orientation, Transformations play a 

crucial role in computer graphics. 

TRANSLATION 

 An object is moved to a different position on the screen by using translation. 

A point in 2D can be translated by adding translation coordinate (tx, ty) to the original 

coordinate (X, Y) to get the new coordinate (X’, Y’). 

 

From the above figure, It is written that − 

X’ = X + tx 

Y’ = Y + ty 
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ROTATION 

The object can be rotated at a particular angle θ (theta) from its origin using 

the Rotation option. It is observed that the point P(X, Y) is located at angle φ from 

the horizontal X coordinate with distance r from the origin. 

It is assumed that a point is rotated at angle θ. After rotating to the new location,  

a new point P’ (X’, Y’) appears.  
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Using standard trigonometric the original coordinate of point P(X, Y) can be 

represented as −

 

 

Representing the above equation in matrix form 
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SCALING 

To change the size of an object, scaling transformation is used. In the scaling 

process, you either expand or compress the dimensions of the object. Scaling can 

be achieved by multiplying the original coordinates of the object with the scaling 

factor to get the desired result. 

 

Where S is the scaling matrix. The scaling process is shown in the following figure. 
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Before Scaling/ After Scaling 

If we provide values less than 1 to the scaling factor S, then we can reduce the size 

of the object. If we provide values greater than 1, then we can increase the size of 

the object. 

 

 

REFLECTION 

Reflection is the mirror image of original object. In other words, we can say 

that it is a rotation operation with 180°. In reflection transformation, the size of the 

object does not change. 
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The following figures show reflections with respect to X and Y axes, and about the 

origin respectively. 

 

SHEAR 

A transformation that slants the shape of an object is called the shear 

transformation. There are two shear transformations X-Shear and Y-Shear. One 

shifts X coordinates values and other shifts Y coordinate values. However; in both 

the cases only one coordinate changes its coordinates and other preserves its 

values. Shearing is also termed as Skewing. 

X-Shear 

The X-Shear preserves the Y coordinate and changes are made to X coordinates, 

which causes the vertical lines to tilt right or left as shown in below figure. 
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Y-Shear 

The Y-Shear preserves the X coordinates and changes the Y coordinates which 

causes the horizontal lines to transform into lines which slopes up or down as 

shown in the following figure. 

 

BASIC CONCEPTS OF SOUND/ AUDIO DEVICES 

Sound is simply a type of energy vibrating through a medium (such as air or 

water); this energy, within a specific range of frequencies, is interpreted by the 

human ear as sound. 

Sound is made up of three basic elements: 

 Frequency: how fast the vibrations are occurring 
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 Intensity: how loud the sound is 

 Timbre: the sound's quality 

The human ear can detect sound frequencies ranging from 20 to 20,000 Hz. 

However, the human ear is more sensitive to (i.e. able to discern at lowest intensity) 

frequencies ranging between 2,000 and 5,000 Hz. Recall that Hertz (Hz) is a unit 

defined as cycles per second. 

A sound's intensity corresponds to the amount of energy associated with that 

sound. The decibel (dB) is used for measuring the sound's energy in a way that is 

relevant to how humans perceive loudness. 

In the context of audio, the decibel is defined as follows: 

dB = 10 log10 (I/I0) 

where 

I = the measured intensity (W/m2) 

I0 = 10-12 W/m2, which represents the lowest sound intensity detectable by the 

human ear. 

Digital audio is a representation of an analog audio signal used by computers 

and digital devices to record and playback sound. Similar to the frames of a video, 

digital audio is made up of a series of samples which recreate a sound when played 

back in sequence. There are many formats of digital audio, which can have varying 

fidelity and dynamic range. 

Theory 

Digital audio is inherently limited. While acoustical sound and analog signals 

are comprised of actual fluid waves, digital audio is only an approximation of the 

real thing. Like a video made up of frames, digital audio is a series of samples. 

 

This article will focus on Pulse Code Modulation (PCM), the most commonly 

used system for encoding digital audio. Other systems, such as DTS and Dolby 

Digital, also exist but are more prevalent in the film and technology industries. 
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In PCM audio, signals are sampled many times per second, each sample 

recording the wave’s amplitude at one particular moment. Since analog waveforms 

cannot be perfectly recreated, each sample is rounded up or down (quantized) to 

the nearest value. When these samples are played back in sequence, sounds can 

be accurately recreated. 

Just as analog audio is defined by the values of frequency and amplitude, 

digital audio has two main two parameters: sample rate and bit depth. Sample rate 

is how many times per second the sound is sampled, and bit depth is the amount 

of dynamic range each sample is capable of capturing. 

SAMPLE RATE 

The standard CD-quality sample rate of 44.1kHz may seem like a random 

choice, but it's based on the Nyquist-Shannon Sampling Theorem—a principle 

stating that the sample rate must be more than twice the highest frequency to be 

captured. Since the upper limit of human hearing is 20kHz, a sample rate greater 

than 40kHz is necessary to capture the entire range (the extra 4.1kHz helps avoid 

aliasing, a form of distortion). In theory, 44.1kHz should be all we need to 

accurately reproduce any sound, but higher rates do exist. 

The next most common sample rate is 48kHz, and it's the dominant standard 

for film and video sound. This is because it's designed to integrate with the existing 

frame-rate standard for film, 24 frames per second (FPS). Similar to the Nyquist 

frequency, 24 FPS happens to be the magic number for making a series of pictures 

look like a fluid moving image. The audio sample rate must be a multiple of the 

frame-rate in order to stay in sync. 44.1kHz would cause a noticeable drift over 

time, hence 48kHz. 

Higher sample rates are also widely used, but their necessity is debated. 

Proponents claim the ultra-high frequency content subtly increases fidelity and 

adds “air” to the signal, while critics argue that 44.1 is good enough and that 

anything higher simply creates larger files and the potential for artifacts when 

dithering down to lower sample rates. 

Higher sample rates are always multiples of 44.1 or 48. For example, 88.2, 96, and 

192kHz are all common options on modern equipment and software. 
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BIT DEPTH 

The bit depth of a file determines its dynamic resolution, similar to a digital 

photograph. Each bit can convey four amplitude values (two positive and two 

negative), so more bits per sample means greater dynamic range. 

This doesn't mean one bit depth is “louder” than another, but higher bit 

depths will sound more realistic, as they're able more accurately recreate sounds 

(like a high-resolution photo). Here's a rundown of common sample rates and their 

stats: 

 4-bit: 16 possible values, 24dB dynamic range. Sometimes used for 

extremely low-fi “bitcrushed” audio effects. 

 8-bit: 256 possible values, 48dB dynamic range. Used by early systems such 

as classic video games. 

 16-bit: 65,536 possible values, 96dB of dynamic range. Standard bit depth of 

audio CDs. 

 24-bit: 16,777,216 possible values, 145dB dynamic range. Most commonly 

used bit depth. 

 32- or 64-bit “floating point”: a recent advancement which provides better 

signal-to-noise ratio, but has yet to be widely adopted. 

 

FORMATS 

PCM audio can be encoded in many formats for the end user, and these 

formats fall into two categories: lossless and lossy. Lossless formats perfectly 

preserve whatever information was captured at the time of recording but can take 

up a lot of hard drive space. 

Lossy formats create compressed files (note: data compression is different 

from audio compression) which take up significantly less hard drive space but can 

sacrifice some audio quality or result in unpleasant artifacts. Here’s a rundown of 

the most common formats: 
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1- LOSSLESS FORMATS 

.WAV (Waveform Audio File Format): commonly used by recording equipment to 

capture raw, uncompressed audio. Broadcast WAV Files (.BWF) are able to store 

additional metadata. 

.AIFF (Audio Interchange File Format): similar to WAV, but proprietary to Apple 

devices. 

.FLAC (Free Lossless Audio Codec): an open-source format which compresses files 

without sacrificing sound quality but is not supported by all players. 

.ALAC (Apple Lossless Audio Codec): slightly less efficient than FLAC, but 

compatible with Apple devices. 

2- LOSSY FORMATS 

.mp3 (Mpeg Audio Layer III): by far the most common compressed format, 

popularized during the advent of portable music players. 

.AAC (Advanced Audio Coding): an alternative designed to improve on the quality 

of mp3. 

.OGG (Ogg Vorbis): an open source alternative used certain video games, but not 

as popular with individual users. 

DATA COMPRESSION: LEMPEL-ZIV 

There are two categories of compression techniques, lossy and lossless. 

Whilst each uses different techniques to compress files, both have the same aim: 

To look for duplicate data in the graphic (GIF for LZW) and use a much more 

compact data representation. Lossless compression reduces bits by identifying and 

eliminating statistical redundancy. No information is lost in lossless compression. 

On the other hand, Lossy compression reduces bits by removing unnecessary or 

less important information. So we need Data Compression mainly because: 

Uncompressed data can take up a lot of space, which is not good for limited hard 

drive space and internet download speeds. 



DEPARTMENT OF COMPUTER SCIENCE 
 

 

BCA-402 
Computer Graphics & Packages 

 

P
ag

e2
9

 

While hardware gets better and cheaper, algorithms to reduce data size also helps 

technology evolve. 

Example: One minute of uncompressed HD video can be over 1 GB.How can we fit 

a two-hour film on a 25 GB Blu-ray disc? 

Lossy compression methods include DCT (Discreet Cosine Transform), Vector 

Quantisation and Transform Coding while Lossless compression methods include 

RLE (Run Length Encoding), string-table compression, LZW (Lempel Ziff Welch) and 

zlib. There Exist several compression Algorithms, but we are concentrating on LZW. 

LOSSLESS MODE 

Lossless compression is a class of data compression algorithms that allows 

the original data to be perfectly reconstructed from the compressed data. Some 

image file formats, like PNG or GIF, use only lossless compression, while others like 

TIFF and MNG may use either lossless or lossy methods. 

JPEG: IMAGE PREPARATION 

JPEG coded images are used in many applications with graphical functions, 

for example in Web browsers. Here, the images are transferred in coded form and 

are represented in decoded form. Image Compression: Preparation: In the first step 

of an image compression process the images are prepared for the actual 

processing. 

MPEG, PRODUCTION STANDARDS 

The MPEG standards are an evolving set of standards for video and audio 

compression and for multimedia delivery developed by the Moving Picture Experts 

Group (MPEG). MPEG-2 was designed for coding interlaced images at transmission 

rates above 4 million bits per second. MPEG-2 is used for digital TV broadcast and 

DVD. 
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UNIT- II, III 

INTRODUCTION TO CORELDRAW: 

Coreldraw is vector based designing software which is used for creating logos, 

flexes, brochures, invitation cards and any kind of vector designing based on the 

lining. CorelDraw is a software program for editing vector graphics, this is very old 

software which was released 29 years ago on 16th January 1989. It was developed 

by Corel Corporation so it is also known as Corel’s Graphic Suite. 

Vector graphics are created in graphics packages and consist of objects. Each object 

can be edited separately, meaning that the shape, colour, size and position can be 

changed. 

Developed by Ottawa-based software company, Corel, CorelDraw, styled 

CorelDRAW, allows users to do things like add special effects such as borders to 

images, in addition to allowing for contrast adjustment, colour balancing and more. 

One of the handy features of the software is that it can also work with multiple 

layers and multiple pages. 

CONCEPTS OF GRAPHIC DESIGNING 

Graphic design is art with a purpose. It involves a creative and systematic plan to 

solve a problem or achieve certain objectives, with the use of images, symbols or 

even words. It is visual communication and the aesthetic expression of concepts 

and ideas using various graphic elements and tools. 

INTERFACE 

The CorelDraw X7 Interface 

A program's interface refers to the way it looks and to the controls, dialog boxes, 

and other components that enable you to interact with it. Figure 1.8 shows the 

important parts of the CorelDraw 10 interface. 
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Figure- 1. The CorelDraw 10 interface. 

1. Title bar. Displays the program name and name/location of the active 

document. 

2. Menu bar. Click any menu title (such as File or Edit) to choose commands. 

3. Standard toolbar. One of twelve command bars, the Standard toolbar's 

icons provide quick access to common Windows commands, such as New, 

Open, Save, and Print. It also includes CorelDraw commands, such as 

Import, Export. 

USES 

Coreldraw is vector based designing software which is used for creating logos, 

flexes, brochures, invitation cards and any kind of vector designing based on the 

lining. 

OPEN 

Open all native file format- such as .cdr, .ai, .pdf, .eps etc. 
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IMPORT 

Open Non-native file format- such as .JPEG, .PNG, .BMP, .TIFF etc. 

SAVE 

Save the current document.  

SAVE AS 

Save the document with different file format. 

CLOSE 

Close the current document.  

CLOSE ALL 

Close the all document. 

SPECIFYING THE PAGE LAYOUT 

You can begin working on a drawing by specifying settings for the size, orientation, 

and layout style of the page. The options you choose when specifying the page 

layout can be used as a default for all new drawings you create. You can also adjust 

the page size and orientation settings to match the standard paper settings for 

printing. 

PAGE SIZE 

There are two options for specifying a page size: choosing a preset page size and 

creating your own. You can choose from many preset page sizes, ranging from 

legal-size paper and envelopes to posters and Web pages. If a preset page size does 

not meet your needs, you can create a custom page size by specifying a drawing’s 

dimensions. 

You can save custom page sizes as presets for later use, and you can delete any 

custom preset page sizes that you no longer need. 
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PAGE ORIENTATION 

The orientation of the page can be landscape or portrait. In landscape 

orientation, the drawing’s width is greater than its height, and in portrait 

orientation, the drawing’s height is greater than its width. Any pages you add to a 

drawing have the current orientation; however, you can change the orientation of 

individual pages at any time. 

LAYOUT STYLES 

When you use the default layout style (Full Page), each page in a document 

is considered a single page and prints on one sheet. You can choose layout styles 

for multipage publications, such as booklets and brochures. The multipage layout 

styles- Book, Booklet, Tent Card, Side-fold Card, Top-fold Card, and Tri-fold 

Brochure- split the page size into two or more equal parts. Each part is considered 

a separate page. The advantage of working with separate parts is that you can edit 

each page in upright orientation, and in sequential order in the drawing window, 

regardless of the layout required to print your document. When you are ready to 

print, the application automatically arranges the pages in the order required for 

printing and binding. 

LABEL STYLES 

You can choose from more than 800 preset label formats from different label 

manufacturers. You can preview the dimensions of labels and see how they fit on 

a printed page. If CorelDRAW does not provide a label style that meets your 

requirements, you can modify an existing style or create and save your own original 

style. 

BASIC SHAPES 

There are so many drawing basic shapes - such as rectangles, ellipses, 

polygons, and stars - is quick and easy. All the tools you need are easily accessible 

from the following flyouts in the toolbox: the Rectangle flyout, the Ellipse flyout, 

and the Object flyout. 
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FILL AND OUTLINE 

Just double-click a color swatch on the status bar, which appears at the bottom 

of the application window. 

 Double-click the Fill color swatch to bring up the Edit Fill dialog box, and edit 

the fill. 

 Double-click the Outline color swatch to bring up the Outline Pen dialog box, 

and edit the object outline. 

VECTOR GRAPHICS AND RASTER GRAPHICS 

There are two basic types of digital graphic images existing on the web: 

vector and raster (bitmap images).  

1. Scalability of vector and raster 

The first factor that will help you define whether a certain image is in vector 

or raster format, is scalability. Vector images don’t lose their sharpness and clarity, 

no matter to what extend or how many times you change their size. 

In contrast, raster (or bitmap) images get blurry and pixelated once you examine 

them from a close-up. Let’s illustrate it for you, so you can better see the difference. 

In the following illustration you will see a raster image which loses quality when 

enlarged. In comparison to it, a vector version of the same monster illustrated next 

to the raster doesn’t change its quality no matter the size: 

2. Resolution of vector and raster 

There is a significant difference of how the resolutions of vector and raster 

formats are defined. The resolution of the raster graphics is formed by millions of 

square pixels, dots per inch (DPI) or pixels per inch (PPI), so their size is always a 

fixed value. If you don’t want a bitmap image to lose its quality, you can only scale 

it down. Consequently, the more you expand it, the more blurred it becomes. 

Vector graphics, on the other hand, are made up of plenty of paths, 

mathematically defined in terms of ratios, proportions, width, height and other 

dimensions. Every time you resize a vector image, its lines, curves and nodes are 
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recalculated, so the result image remains sharp and clear. As you can expect, the 

edges remain smooth at all times. 

 

3. Creation of vector and raster 

The digital image creation is always quite different for the two types. Vector 

images can be easily transformed into raster ones but it is more complicated and 

time-consuming to work the other way around. 

Vector graphics can be only created with a specialized software such as 

CorelDraw, Adobe Illustrator. This makes it impossible for photos, for example, to 

be taken in vector format. In addition to this, all printed images and photos taken 

with digital cameras, are in raster format. All in all, vector graphics which resemble 

realistic photos, are nothing but finely detailed digital illustrations.  

4. Flexibility of vector and raster 

Vector graphics can be resized numerously without losing quality. This makes 

them perfect for multipurpose projects requiring flexibility in the image size. For 

example, a vector logo is a reliable source from which you can create rasters in 

different sizes. You can use them for various marketing needs you’ll be facing in the 

future, either print, or web. On the contrary, you need a particular size of a raster 

format to achieve a certain quality. 

5. File size 

Vector images are quite lighter than their raster peers because their 

dimensions are defined by mathematical calculations and not by millions of pixels. 
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The high efficiency of their file sizes makes them much more convenient to transfer 

them from one device to another. Plus, they carry a lot of information in a relatively 

small file size format (compared to the same file size of a raster image format). 

On the other hand, raster file sizes are defined by their DPI or PPI, fixed widths and 

heights, which makes them much heavier while containing less information. 

6. Compatibility of vector and raster 

Sometimes, an issue is the compatibility of vector graphics. You can only 

open and edit them with a specialized software such as CorelDraw, Adobe 

Illustrator. One of the most common vector file extensions: .eps. You can use this 

vector format as an alternative for editing, when you don’t have the .cdr or .ai file. 

In contrast to vectors, raster file formats are widely popular and recognizable 

by all common image programs. Also, most digital images on the web are actually 

bitmaps even if they were vectors once. This makes bitmaps very convenient for a 

mass use. One of the most raster transparent format: .png. 

7. Printing 

It’s true that 72 dpi raster images are usually the norm for web publications 

and they work just fine. For their printed version, though, you have two options.  

You should either work with vector source, or use high-resolution raster files. The 

latter option is often the preferred one, because, sometimes, vector images are not 

accurately printed.  If you don’t want to compromise on the image’s clarity, the 

recommended raster resolution is 300 dpi. Since you can’t save photos as vectors, 

printed magazines, newspapers, etc. use the photos in their high-resolution rasters. 

NAME VECTOR FILE FORMAT 

.CDR, .Ai, .SVG, .DXF, .DWG, .CMX, .PDF, .EPS etc. 

NAME OF RASTER FILE FORMAT 

.JPEG, .GIF, .PNG, .TGA, .TIFF, .BMP, .CPT, .PSD, .SWF etc. 
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EDIT, VIEW AND ARRANGE MENU 

EDIT: All editing tools are available in this tab. 

VIEW: If a document contains multiple pages, you can view them all at once by 

using the Page Sorter view. You can also display consecutive left-hand and right-

hand pages on the screen at the same time (facing pages) and create objects that 

span two pages. Click Window Dockers View manager. Click the Add current view 

button 

ARRANGE: The “Arrange” menu is found in the “Drawing” group of the Home tab. 

You must select a specific object to arrange. For this example, the image of the 

flower on the left has been selected. The dropdown Arrange menu provides you a 

variety of options. 

ALL TOOLS 

 Pick tool - Select, position, or transform objects. 

 Freehand Pick tool - Select objects by using a freehand selection marquee. 

Position and transform objects. 

 Shape tool- (F10) - Edit a curve object or text character by manipulating 

nodes. 

 Smudge Brush tool - Change the shape of an object by dragging along its 

outline. 

 Roughen Brush tool - Distort the edge of an object by dragging along its 

outline. 

 Free Transform tool - Rotate, skew, mirror, and scale objects. 

 Smear tool - Change the edge of an object by dragging along its outline. 

 Twirl tool - Add swirl effects by dragging along the outline of an object. 

 Attract tool - Reshape objects by attracting nodes to the cursor. 

 Repel tool - Reshape objects by pushing nodes away from the cursor. 

 Smooth tool - Smooth object by dragging along its outline. 

 Crop tool - Remove the areas outside a selection. 

 Knife tool - Slice an object to split it into two separate objects. 

 Eraser tool (X) - Remove unwanted areas in a drawing. 

 Virtual Segment Delete tool - Remove overlapping segments in objects. 
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 Zoom tool (Z) - Change the magnification level of the document window. 

 Pan tool (H) - Drag hidden areas of a drawing into view without changing the 

zoom level. 

 Freehand tool (F5) - Draw curves and straight line segments. 

 2-Point Line tool - Draw a straight line by drawing from the starting point to 

the endpoint. 

 Bezier tool - Draw curves one segment at a time. 

 Artistic Media tool (I) - Add artistic brush, spray, and calligraphic effects by 

using freehand strokes. 

 Pen tool - Draw curves in segments, and preview each segment as you draw. 

 B-Spline tool - Draw curved lines by setting control points that shape the 

curve without breaking it into segments. 

 Polyline tool - Draw connected curves and straight lines in one continuous 

action. 

 3-Point Curve tool - Draw a curve by dragging from the starting point to the 

endpoint and then positioning the center point. 

 Smart Fill tool - Create objects from overlapping areas, and apply a fill to 

those objects. 

 Smart Drawing tool (Shift+S) - Convert freehand strokes to basic shapes or 

smoothed curves. 

 Rectangle tool (F6) - Draw squares and rectangles by dragging in the drawing 

window. 

 3-Point Rectangle tool - Draw rectangles at an angle. 

 Elipse tool (F7) - Draw circles and elipses by dragging in the drawing window. 

 3-Point Elipse tool - Draws elipses at an angle. 

 Polygon tool (Y) - Draw polygons by draggig in the drawing window. 

 Star tool - Draw uniform, outlined stars. 

 Complex Star tool - Draw stars that have intersecting sides. 

 Graph Paper tool (D) - Draw a grid. 

 Spiral tool (A) - Draw symmetrical and logarithmic spirals. 

 Basic Shapes tool - Draw triangles, circles, cylinders, hearts and other 

shapes. 
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 Arrow Shapes tool - Draw arrows of various shapes and directions. 

 Flowchart shapes tool - Draw flowchart symbols. 

 Banner Shapes tool - Draw ribbon objects and explosion shapes. 

 Callout Shapes tool - Draw labels and speech bubbles. 

 Text tool (F8) - Add and edit paragraph and artistic text. 

 Table tool - Draw, select, and edit tables. 

 Parallel Dimension tool - Draw slanted dimension lines. 

 Horizontal or Vertical Dimension tool - Draw horizontal or vertical 

dimension lines. 

 Angular Dimension tool - Draw angular dimension lines. 

 Segment Dimension tool - Display the distance between end nodes on single 

or multiple segments. 

 3-Point Callout tool - Draw a callout with a two-segment leadingline. 

 Straight-Line Connector tool - Draw a straight line to connect two objects. 

 Right-Angle Connector tool - Draw a right angle to connect two objects. 

 Right-Angle Round Connector tool - Draw a right angle with a rounded 

corner to connect two objects. 

 Edit Anchor tool - Modify the connector line anchor points of objects. 

 Blend tool - Blend objects by creating a progression of intermediate objects 

and colors. 

 Contour tool - Apply a series of concentric shapes that radiate into or out of 

an object. 

 Distort tool -Transform objets by applying Push and Pull, Zipper, or Twister 

effects. 

 Drop Shadow tool - Apply shadows behind or below objects. 

 Envelope tool - Change the shape of an object by applying and dragging the 

nodes of an envelope. 

 Extrude tool - Apply 3D efect to objects to create the illusion of depth. 

 Transparency tool - Partially reveal image areas underneath the object. 

 Color Eyedropper tool - Sample colors, and apply them to objects. 

 Outline Pen (F12) - Set outline properties sucj as line thickness, corner shape, 

and arrow type. 
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 Outline Color (Shift+F12) - Choose the outline color by using color viewers 

and color palettes. 

 Uniform Fill (Shift+F11) - Choose a solid fill color for an object by using color 

palettes, color viewers, color harmonies, or color blends. 

 Fountain Fill (F11) - Fill an object with a gradient of colors or shades. 

 Pattern Fill - Apply a preset pattern fill to an object or create a custom 

pattern fill. 

 Texture Fill - Apply preset texture fills to objects to create the illusion of a 

variety of textures, such as water, clouds and stone. 

 PostScript Fill - Apply an intricate PostScript texture fill to an object. 

 Interactive Fill tool (G) - Create a fill dynamically by using markers in the 

drawing window and property bar to change the angle, midpoint, and color. 

 Mesh Fill tool (M) - Fill an object by blending multiple colors or shades 

arranged over a mesh grid. 

COLOR STYLE 

In CorelDRAW, a color style is a color that you save and apply to objects in a 

CorelDRAW design. Any time you update a color style, you also automatically 

update all objects using that color style. 

PALETTE EDITOR 

A custom color palette is automatically created on the fly for each design 

project. The palette is saved with the file to help you keep track of the colors that 

you use by storing them for future use. 

DOCKERS 

Dockers are something in between toolbars and dialog boxes. They offer a 

lot of functionality for specific tasks. There is a lot of overlap between functions 

offered through dockers and the active property bars. 

TEXT TOOL 

The text tool is used add text to illustrations. There are two kinds of text in 

Coreldraw; artistic text and paragraph text. Instead of editing the lines and 

characters, you determine the shape of a container for the text to reside in. 
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 Artistic text is used for small amounts of texts, usually just one or two lines, 

it works well for things like headings, text effects and captions. The 

appearance and placement of artistic text can be thoroughly manipulated, 

character per character if necessary. Paragraph text is used for adding large 

amounts of text. 

 Paragraph text, also known as "block text," is generally reserved for larger 

bodies of text that have greater formatting requirements. For example, you 

can use paragraph text when creating brochures, newsletters, catalogs, or 

other text-intensive documents. You can insert a text frame directly in the 

drawing window. 

FORMAT TEXT 

CorelDRAW offers various formatting options for paragraph text. For 

example, you can fit text to a paragraph text frame. Fitting text to a text frame 

increases or decreases the point size of text so that it fits the text frame exactly. 

You can also use columns to lay out text-intensive projects, such as newsletters, 

magazines, and newspapers. You can create columns of equal or varying widths 

and gutters. 

Applying drop caps to paragraphs enlarges the initial letter and insets it into 

the body of text. You can customize a drop cap by changing its settings. For 

example, you can change the distance between the drop cap and the body of text, 

or specify the number of lines of text that you want to appear next to the drop cap. 

You can remove the drop cap at any point, without deleting the letter. 

You can use bulleted lists to format information. You can have text wrap 

around bullets, or you can offset a bullet from text to create a hanging indent. 

CorelDRAW lets you customize bullets by changing their size, position, and distance 

from text. You can also change the spacing between items in a bulleted list. After 

you add a bullet, you can remove it without deleting the text. 

You can add tab stops to indent paragraph text, remove tab stops, and 

change the alignment of tab stops. You can also set tab stops with trailing leader 

characters, so that dots automatically precede the tab stops. 
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When adding drop caps, bullets, tab stops, and columns, you can save time 

by previewing all the changes you make before committing to them. When you 

preview the changes, they are temporarily applied directly to the text in the 

drawing window. You can see exactly how the new settings would affect your 

drawing if they were applied. 

Indenting changes the space between a paragraph text frame and the text 

that it contains. You can add and remove indents without deleting or retyping text. 

You can indent an entire paragraph, the first line of a paragraph, or all lines of a 

paragraph except the first line (a hanging indent). You can also indent from the 

right side of the text frame. 

You can change the formatting of selected paragraph text frames, or of 

selected text frames plus the text frames with which they are currently linked. For 

information about setting these options. 

WRAP PARAGRAPHIC TEXT 

You can also adjust the amount of space between paragraph text and the object 

or text, and you can remove any previously applied wrapping style. Select the 

object or text around which you want to wrap text 

 To wrap paragraph text around an object, artistic text, or a text frame 

 To remove a wrapping style 

ARTISTIC MEDIA 

Artistic media tool is a revolutionary result of Corel DRAW's Power line 

feature which is now called “Preset”. This media tool surrounds your drawn lines 

with specific preset vector object and can quickly change the look of a simple 

object, text or a line into a state of the art graphics 

LENS 

You can apply lenses to any vector object, such as a rectangle, ellipse, closed 

path, or polygon. You can also change the appearance of artistic text and bitmaps. 

When you apply a lens over a vector object, the lens itself becomes a vector image. 

After you apply a lens, you can copy it and use it with another object. 
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POWERCLIP 

Clipping Objects into other Objects Using PowerClip. The PowerClip tool in 

CorelDRAW allows you to place vector objects and bitmaps, such as photos, inside 

other objects, or frames. A frame can be any object, for example artistic text or a 

rectangle. 

ADD PERSPECTIVE 

Adding perspective to objects creates the illusion of distance and depth. You 

can create a perspective effect by shortening one or two sides of an object. 

CorelDRAW lets you use perspective with both vector and bitmap objects. You add 

perspective to a bitmap interactively in the drawing window. 

INTERACTIVE FILL TOOL 

Interactive Fill Tool and Interactive Mesh Fill Tool. The interactive fill tool 

allows you to add the same fills to objects as the normal fill tool, but in an 

interactive way; you set the fills properties in an interactive way. This is especially 

useful for fountain fills. 

GRAPHIC STYLES 

A style is a set of formatting attributes which you can apply to an object, or 

several objects, in one step. Styles are especially useful when working on 

documents containing multiple common elements, such as text formatting and 

graphic colors. 

SYMBOL 

Symbols are objects that are defined once and can be referenced many times 

in a drawing. You can have multiple instances of a symbol in a drawing with little 

impact on file size. Symbols make editing a drawing quicker and easier, as changes 

made to a symbol are automatically inherited by all instances. 

Using symbols for objects that appear many times helps to reduce file size. 

Symbols are created from objects. When you convert an object to a symbol, the 

new symbol is added to the Symbol manager docker, and the selected object 
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becomes an instance. You can also create a symbol from multiple objects. Most 

objects in CorelDRAW can be converted to symbols, with some exceptions.  

The symbols that you create in a drawing are saved with the CorelDRAW 

(CDR) file. In addition, you can create symbol libraries, which contain symbols that 

can be shared between drawings.  

You can edit a symbol; any changes you make affect all instances in the 

drawing. The selection handles for symbols differ from those for objects. Selection 

handles for symbols are blue; selection handles for objects are black. When you 

insert a symbol from an external library, a copy of the symbol is added to the active 

drawing, but it remains linked to the source symbol. You can edit a linked symbol 

or you can decide to break the link to the external library and make the symbol 

internal. When the link is broken, the local copy of the symbol remains in the 

drawing as an internal symbol, and it can be edited independently from the symbol 

in the external library. 

You can delete a symbol. When you delete a symbol that is used in a 

document, all instances of the symbol are removed from the document. You can 

also delete all symbols that are stored in the document library but are not used in 

the document. 

INSERT CHARACTER 

Click in the Character and glyph list, hold down Alt, and type the Alt code for 

the character you want. Press the corresponding key on the keyboard. Click Text 

Insert character. In the Insert character docker, choose a font from the Font list 

box. 

BITMAP AND EFFECTS 

Bitmap images are images defined in the form of small dots called pixels. Unlike 

Vector images, these are not defined in terms of curve and lines. There are two 

properties of Bitmap images. 

 Resolution 

 Number of color in the image. 
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Resolution is expressed in dots per inch (dpi). For a computer monitor 72 is ideal 

but for printing purpose 300 or 600 dpi is widely used. You can import bitmap 

images in the same way as import other image formats. Can also convert any of 

your image into a bitmap image. 

Convert an image into bitmap image, do this: 

1. Select the image which is to be converted. 

2. Click Bitmaps menu and choose Convert to Bitmap 

3. The Convert to Bitmap dialog box appear.  

4. In the dialog box, choose a color mode from the Color: drop down menu. 

5. Specify a resolution of your choice in the Resolution: List box 

6. To eliminate jagged edges in the image disable the Anti-aliasing check box. 

7. To eliminate any colored background in the image, check the Transparent 

Background check box. 

8. Click OK. 

CROPPING BITMAPS 

Cropping a bitmap image means cutting it short. In other words cropping an 

image means trimming an image. 

To crop a bitmap image, do this: 

1. Select the image. 

2. Click Shape flyout and choose Shape Tool. 

3. Drag inward the nodes of the image in the direction in which you want to 

crop 

4. Now if you reverse the process you can get back the whole image, If you want 

to completely remove the cropped part, click Bitmaps menu and chose Crop 

Bitmap. 
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BITMAP SPECIAL EFFECTS 

You can apply a range of useful effects to bitmaps images. These effects are 

Color masking i.e. removing a selected color from the image, transforming color, 

applying contour, etc. Most of these effects are available in the Bitmap menu. Some 

of them are explained here. 

To apply 3D effects, do this: 

1. Select the image. 

2. Click Bitmaps menu, highlight 3D Effects and choose the effect that you want 

to apply. 

3. As an Example, choose Emboss. Emboss dialog box appear.  

4. Slide the Depth: and the Level: slider to specify the emboss depth and level. 

5. Also specify the angle at which light hits the engraving in the Direction: 

6. Choose an embossing color from the Emboss color area. Use the eyedropper 

button to select a color from outside the dialog box. 

7. Click OK. 

To apply Art Stroke, do this: 

1. Select the image. 

2. Click Bitmaps menu, highlight Art Stroke and choose from any of the 

available. 

3. As an example, choose Pastels. 

4. In the Pastel Type area, choose Soft for a soft pastel or choose Oil fro a 

smudged pastel. 

5. Slide the slider of the Stroke size: to set the size of brushstroke. 

6. Set the color variations of brushstrokes in the Hue Variation: area. 

7. Click OK.  

You will observe two small buttons on the top right corner of the Pastel dialog 

box. These buttons are seen in almost all the effects dialog box. Clicking on the first 

button will show the before and after applying effect preview of the image. The 

second image shows the effect in a single preview window. At the top left cornet 
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of each of the Effect dialog box, there is a small triangle. Clicking on it will show all 

the effects available in Bitmaps menu in a drop down menu. 

To transform color, do this: 

1. Select the image. 

2. Click Bitmaps menu, highlight Color Transform and choose from any of the 

available options. 

3. As an example, choose Psychedelic… The Psychedelic box appear. 

4. Set the level and Click OK. 

To distort images, do this: 

1. Select the image. 

2. Click Bitmaps menu, highlight Distort and choose from any of the available 

options. 

3. As an example, choose Ripples…. The Ripples dialog box appear.  

4. Set the Angle in the Angle: list box. 

5. Click OK.  

  To add noise, do this: 

1. Select the image. 

2. Click Bitmaps menu, highlight Noise and choose Add Noise. Add Noise dialog 

box appear. 

3. Specify noise type in the Noise Type area. 

4. Specify level and density by dragging the level and Density slider respectively. 

5. Click OK. 

6. Choose a color mode from the Color mode area.  

It is not possible to discuss here each and every effect, available fro Bitmap images. 

Experiment with the remaining effects yourself. 

COLOR MASKING 

Color masking removes pixels having a selected color. 
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To apply color mask to a bitmap image, do this: 

1. Select the image. 

2. Click Windows menu and choose Bitmap Color Mask, The Bitmap Color Mask 

docker appear. 

3. Click on the Hide Color option on the docker window. 

4. Slide the Tolerance slider to specify the exactness of the color to be removed. 

5. Now click the Eyedropper icon and click on the color in the image which is to 

removed. 

6. You will observe that the chosen color appears in the first bar of the Bitmap 

Color Mask rollup. 

7. When the color in the rollup matches the color you want to delete, click 

Apply. Watch that color, and, any other similar colored pixels (depending on 

the Tolerance) disappear. 

8. If you need to delete additional colors from your bitmap image, use the 

remaining bars in the Bitmaps Color Mask rollup. But before you click Apply, 

disable the check boxes next to the color which you don’t want to remove. 

9. To reset the previous color of the image, click on the Remove Mask button. 

RESIZING & ROTATING/SKEWING IMAGES 

Images are treated as any other object when it comes to performing 

transformations on the, like resizing, skewing etc. You are already familiar with 

transforming objects using the Transformations docker Window. The same process 

applies for all images, be it Vector or Bitmap image. 

EXPORTING IMAGE 

You can export CorelDRAW image to a different file format. This is useful 

when you want an image to visible to anyone, even if he dies not have a CorelDRAW 

compatible package. For example, if you want to use an image on a Web Site, you 

will need to export the image into a GIF or JPG format. In CorelDRAW you can also 

export an image in PDF format. PDF format is widely accepted for printing and Web 

based applications. 
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To export an image, do this: 

1. Click File menu and choose Export. 

2. In the Export dialog box, select the folder in which you want to save the 

image in the Save in: drop down menu. 

3. Choose the file format in which you want to export the image, in the Files to 

type: drop down menu. 

4. Click the Selected only check box to export only the selected portions of the 

image. 

5. Type a name for your file in the File name: text field and click OK. 

LAYOUT STYLES 

CorelDRAW lets you choose a preset layout style for your drawing. You can 

choose the layout style depending on the nature of project you are working on. For 

example, to design a book, click on the Book style. Other options available in 

CorelDRAW are Booklet, Tent Card, Side-fold card and Top-fold card. In a multi-

page document you can set whether you want the page to appear face to face or 

not. 

To set layout styles for the drawing window, do this: 

1. Click the Layout menu and choose Page Setup, The options dialog box 

appears. 

2. Double click in Layout in the left side of the options dialog box. 

3. In the Layout drop down menu, choose a Layout style. 

4. Check the Facing pages check box, if you want the left and right pages to face 

each other. 

5. Click the Start on: list box and choose Left side to start the document on a 

left facing page. 

Click the Right side to start the document on a right facing page. The Start on: list 

box is highlighted only if the Layout chosen is Full page or Book style. 
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INSERTING PAGE NUMBERS 

You can insert page numbers on the current page, all pages, all odd pages, or 

all even pages. When you insert page numbers on multiple pages, a new master 

layer is automatically created, and the page number is placed on it. The master 

layer can be an all-page master layer, an odd-page master layer, or an even-page 

master layer. For more information about master layers, see creating layers. 

Page numbers are automatically updated when you add or delete pages in your 

document. 

You can also insert a page number inside existing artistic or paragraph text. If the 

text is located on a local layer, the page number is inserted on the current page 

only. If the text is located on a master layer, the page number becomes part of the 

master layer and appears on all pages where the master layer is visible. For more 

information about artistic and paragraph text, see Adding and manipulating text. 

If the page numbers are on a master layer, you can hide the page number on a 

specific page by hiding the master layer on that page. 

You can change the default page number settings before or after you insert page 

numbers in your document. For example, you can start the page count at a specific 

number other than 1. This is particularly useful if you want to create multiple 

CorelDRAW files that will be put together as one publication. 

You can also specify whether to start page numbering on the first page or on 

another page. For example, if you choose to start page numbering on page 3, page 

3 displays the number 1. If you insert a new page between 1 and 2, it becomes the 

new page 2, whereas the old page 2 becomes page 3 - the page where the first page 

number is displayed. 

You can also choose from a variety of commonly used page number styles. 

When you save to CorelDRAW X5 or earlier version, page numbers are preserved 

as editable artistic text. However, if you add or delete a page, the page count will 

not be updated. 
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MANIPULATING PAGE NUMBERS AS OBJECTS 

Page numbers are artistic text objects (unless you insert them in paragraph 

text) that can be modified and manipulated like any other artistic text object. For 

example, you can resize, scale, or rotate a page number, change its color, or apply 

effects such as texture fill or a drop shadow. 

When the page number is on a master layer, applying transformations to it affects 

all page numbers. 

The following table lists various ways to manipulate page numbers as objects. 

TO INSERT A PAGE NUMBER  

 Click Layout Insert page number, and choose one of the following 

options: 

 On active layer — lets you insert a page number on the layer that is 

currently selected in the Object manager docker. If the active layer is 

a master layer, page numbers are inserted on all pages of the 

document where the master layer is visible. If the active layer is a local 

layer, the page number is inserted on the current page only. 

 On all pages — lets you insert page numbers on all pages. The page 

number is inserted on a new all-page master layer. 

 On all odd pages — lets you insert page numbers on all odd pages. The 

page number is inserted on a new odd-page master layer. 

 On all even pages — lets you insert page numbers on all even pages. 

The page number is inserted on a new even-page master layer. 

By default, the page number is centered at the bottom of the page. 

PUBLISH TO PDF 

PDF/X is a subset of the PDF ISO standard, designed to facilitate graphics 

exchange. This standard includes a series of print-related requirements that go 

above those of standard PDF files. 
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Whereas previous CorelDRAW versions supported PDF/X-3, CorelDRAW 2019 now 

supports PDF/X-4, with new features that include layers, transparency, Open Type 

fonts, and more. This ensures easy output of files that are compatible with the 

widest range of devices and comply with the latest print-industry standards. 

Export to PDF can be done from File > Publish to PDF or via the Publish to PDF icon. 

In the Publish to PDF window, the PDF Preset dropdown list now includes PDF/X-

4:2010 CMYK. Click the Settings button at the bottom of the Export window to see 

the options for this preset. 

Let’s review some notable features in the PDF Settings window. 

On the General tab: 

Export Range can be used to export the current document or page, or multiple 

documents at once, provided the documents are all currently opened. 

Adjusting the PDF preset and Compatibility options will dictate what options are 

available on the other tabs in the PDF Settings 

Color tab: 

Here you can choose CMYK or Grayscale color output. 

Document tab: 

Here you can generate thumbnails. 

Objects tab: 

Includes options to reduce PDF size with bitmap compression, text and line art 

compression, or downsampling. 

You can also embed fonts to control how the text is output. 

Prepress tab: 

Here you can set the Bleed Limit and enable Printer’s marks such as crop marks and 

registration marks. 
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Security tab: 

With the PDF/X-4 compatibility settings shown in our demonstration, security 

settings are not available. 

Other compatibility settings, such as Acrobat DC for example, allow you to set both 

an open and permissions passwords. 

Now let’s have a look at the Publish to PDF results using the PDF/X-4 format, 

compared to the PDF/X-3 format. 

File Size: After publishing to PDF/X-4, the file size for the PDF document is less than 

1 MB. Using the PDF/X-3 preset, the resulting file size is over 6 MB. 

Layers: When we open the PDF/X-4 document in Adobe Reader, the layers can be 

turned on and off. There are no layers available in the PDF/X-3 document. 

Transparency: In the PDF/X-4 document, the transparent fills are exported 

perfectly even when zoomed in very closely. In the PDF/X-3 document, the quality 

of the transparency is lower, and the edges are not as crisp. This is because previous 

PDF/X versions converted transparent areas to bitmaps at a set resolution, whereas 

PDF/X-4 preserves transparent objects in vector format. 

COLLECT FOR OUTPUT 

The "Collect for output" command that was in the File menu. Its use a lot 

because of converting to lower file versions and automatically collecting all fonts 

and embeds the fonts on the .cdr files. 

 

PRINTING AND PUBLISHING 

CorelDRAW also comes with a full set of printer options that make it easy to 

print business cards, labels, and other odd-sized output. 

Selecting a Printer 

To select a printer do this: 
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1. Click the File menu and choose Print, the Print dialog box appears as in Fig 

2.1. 

 

Figure 2.1: Print dialog box 

2. Click the General Tab. 

3. Select a printer in the Name: list box. 

4. In the Print Range area, the options are: 

 Current document – To print all the pages in your document, click the 

current document radio button. 

 Current page – To print the active page in your document, click the 

current page radio button. 

 Pages – To print range of pages, say, pages 1 to 20 in a 50 page document, 

type the first page number and select the desired page number in the 

pages radio button. Separate the numbers with hyphens like 1-20. 

 In the pages: drop down list, select the desired pages you want. 
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 Documents – To print more than one document at a time click this radio 

button. 

 Selection – To print the selected text, first select it, and then click the 

selection radio button. This option is dimmed unless you have selected 

something in your document. 

5. In the Copies area, the options are: 

 Number of copies: - Specify the number of copies of the document you 

want to print in the number of copies list box. 

 Collate – This option determines how multiple copies are printed. For 

example, if you have a four-page document and you want to print two 

copies, collating prints pages 1,2,3 and 4, and then prints pages 1,2,3, 

and 4 in that order. If you do not select the Collate check box, your two 

copies print in the order of two copies of page 1, followed by two copies 

of page 2, two copies of page 3 and so on. You will need to arrange them 

manually to make the sets. 

6. After making changes click OK to print. 

 

 

UNIT- IV, V 

INTRODUCTION TO ADOBE PHOTOSHOP 

Adobe Photoshop is a raster graphics editor developed and published by 

Adobe Inc. for Windows and MacOS. It was originally created in 1988 by Thomas 

and John Knoll. Since then, the software has become the industry standard not only 

in raster graphics editing, but in digital art as a whole. Photoshop can edit and 

compose raster images in multiple layers and supports masks, alpha compositing 

and several color models including RGB, CMYK, CIELAB, spot color, and duotone. 

Photoshop uses its own PSD and PSB file formats to support these features. In 

addition to raster graphics, this software has limited abilities to edit or render text 

and vector graphics (especially through clipping path for the latter), as well as 3D 

graphics and video. Its feature set can be expanded by plug-ins; programs 
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developed and distributed independently of Photoshop that run inside it and offer 

new or enhanced features. 

Photoshop's naming scheme was initially based on version numbers. 

However, in October 2002 (following the introduction of Creative Suite branding), 

each new version of Photoshop was designated with "CS" plus a number; e.g., the 

eighth major version of Photoshop was Photoshop CS and the ninth was Photoshop 

CS2. Photoshop CS3 through CS6 were also distributed in two different editions: 

Standard and Extended. With the introduction of the Creative Cloud branding in 

June 2013 (and in turn, the change of the "CS" suffix to "CC"), Photoshop's licensing 

scheme was changed to that of software as a service rental model. Historically, 

Photoshop was bundled with additional software such as Adobe ImageReady, 

Adobe Fireworks, Adobe Bridge, Adobe Device Central and Adobe Camera RAW. 

ADOBE CREATIVE SUITE (CS) 

Adobe Creative Suite (CS) is a now-discontinued software suite of graphic 

design, video editing, and web development applications developed by Adobe 

Systems. Each edition consisted of several Adobe applications, e.g., Photoshop, 

Acrobat, Premiere Pro or After Effects, InDesign, and Illustrator that are the 

industry standard applications for many graphic design positions. 

ADOBE CREATIVE CLOUD (CC) 

Adobe Creative Cloud is a set of applications and services from Adobe Inc. 

that gives subscribers access to a collection of software used for graphic design, 

video editing, web development, photography, along with a set of mobile 

applications and also some optional cloud services. In Creative Cloud, a monthly or 

annual subscription service is delivered over the Internet. Software from Creative 

Cloud is downloaded from the Internet, installed directly on a local computer and 

used as long as the subscription remains valid. Online updates and multiple 

languages are included in the CC subscription. Creative Cloud was initially hosted 

on Amazon Web Services, but a new agreement with Microsoft has the software, 

beginning with the 2017 version, hosted on Microsoft Azure. 

Alongside Photoshop, Adobe also develops and publishes Photoshop 

Elements, Photoshop Lightroom, Photoshop Express, Photoshop Fix, Photoshop 
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Sketch and Photoshop Mix. As of November 2019, Adobe has also released a full 

version of Photoshop for the iPad, and while initially limited, Adobe plans to bring 

more features to Photoshop for iPad. Collectively, they are branded as "The Adobe 

Photoshop Family" 

WORKSPACE OVERVIEW 

The Application bar across the top contains a workspace switcher, menus 

(Windows only), and other application controls. On the Mac for certain products, 

you can show or hide it using the Window menu. 

TOOLS PANEL 

The Tools panel contains tools for creating and editing images, artwork, page 

elements, and so on. Related tools are grouped. 

OPTIONS BAR 

The Options bar Control panel displays options for the currently selected 

tool.  

DOCUMENT WINDOW 

The Document window displays the file you’re working on. Document 

windows can be tabbed and, in certain cases, grouped and docked. 

PANELS 

Panels help you monitor and modify your work. Panels can be grouped, 

stacked, or docked. 

APPLICATION WINDOW 

The Application frame groups all the workspace elements in a single, 

integrated window that lets you treat the application as a single unit. When you 

move or resize the Application frame or any of its elements, all the elements within 

it respond to each other so none overlap. Panels don’t disappear when you switch 

applications or when you accidentally click out of the application. If you work with 

two or more applications, you can position each application side by side on the 

screen or on multiple monitors. 
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If you are using a Mac and prefer the traditional, free-form user interface, 

you can turn off the Application frame. 

USABILITY FEATURES 

The Photoshop workspace is easy to use and includes a number of usability 

features: 

 Different brightness levels: Choose Edit > Preference (Windows) or 

Photoshop > Preferences (Mac OS) and select a Color Theme swatch in the 

Interface section. 

Note: To quickly decrease brightness, press Shift + 1; to increase brightness, press 

Shift + 2. (On Mac OS, it’s necessary to also press the FN key.) 

 On-image displays: Stay informed as you use your favorite tools. On-image 

displays show selection dimensions, transformation angles, and more. To 

change the placement of the displays, choose an option from the Show 

Transformation Values in the Interface preferences. 

 Maximized screen space: Click the button at the bottom of the toolbar to 

switch between Standard and Fullscreen display modes. 

 Set UX color: You can customize the interface to sport one of the following 

color themes: Black, Dark Gray, Medium Gray and Light Gray. To do this, 

follow these steps: 

 Choose Edit > Preferences > Interface. 

 Choose the desired color theme. 

 

Available Color Theme options 
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HIDE OR SHOW ALL PANELS 

 To hide or show all panels, including the Tools panel and Control panel, press 

Tab. 

 To hide or show all panels except the Tools panel and Control panel, press 

Shift+Tab. 

Note: You can temporarily display hidden panels if Auto-Show Hidden Panels is 
selected in Interface preferences. Move the pointer to the edge of the application 
window (Windows) or to the edge of the monitor (Mac OS) and hover over the strip 
that appears. 

DISPLAY PANEL OPTIONS 

 Click the panel menu icon in the upper-right corner of the panel. 

Note: You can open a panel menu even when the panel is minimized. 

Note: In Photoshop, you can change the font size of the text in panels and tooltips. 

In the Interface preferences, choose a size from the UI Font Size menu. To scale the 

entire Photoshop UI based on the UI Font Size you've chosen, select the Scale UI To 

Font. 

RECONFIGURE THE TOOLS PANEL 

You can display the tools in the Tools panel in a single column, or side by side in 

two columns. 

 Click the double arrow at the top of the Tools panel. 

MANAGE WINDOWS AND PANELS 

You can create a custom workspace by moving and manipulating Document 

windows and panels. You can also save workspaces and switch among them. 

REARRANGE, DOCK, OR FLOAT DOCUMENT WINDOWS 
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When you open more than one file, the Document windows are tabbed. 

 To rearrange the order of tabbed Document windows, drag a window’s tab 

to a new location in the group. 

 To undock (float or untab) a Document window from a group of windows, 

drag the window’s tab out of the group. 

Note: You can also choose Window > Arrange > Float in Window to float a single 

Document window, or Window > Arrange > Float All in Windows to float all of the 

Document windows at once. 

 To dock a Document window to a separate group of Document windows, 

drag the window into the group. 

 To create groups of stacked or tiled documents, drag the window to one of 

the drop zones along the top, bottom, or sides of another window. You can 

also select a layout for the group by using the Layout button on the 

Application bar. 

 To switch to another document in a tabbed group when dragging a selection, 

drag the selection over the document’s tab for a moment. 

DOCK AND UNDOCK PANELS 

A dock is a collection of panels or panel groups displayed together, generally in 

a vertical orientation. You dock and undock panels by moving them into and out of 

a dock. 

 To dock a panel, drag it by its tab into the dock, at the top, bottom, or in 

between other panels. 

 To dock a panel group, drag it by its title bar (the solid empty bar above the 

tabs) into the dock. 

 To remove a panel or panel group, drag it out of the dock by its tab or title 

bar. You can drag it into another dock or make it free-floating. 

Note: You can prevent panels from filling all the space in a dock. Drag the bottom 

edge of the dock up so it no longer meets the edge of the workspace. 

MOVE PANELS 
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As you move panels, you see blue highlighted drop zones, areas where you 

can move the panel. For example, you can move a panel up or down in a dock by 

dragging it to the narrow blue drop zone above or below another panel. If you drag 

to an area that is not a drop zone, the panel floats freely in the workspace. 

Note: The position of the mouse (rather than the position of the panel) activates 

the drop zone, so if you can’t see the drop zone, try dragging the mouse to the 

place where the drop zone should be. 

 To move a panel, drag it by its tab. 

 To move a panel group, drag the title bar. 

 

Narrow blue drop zone indicates Color panel will be docked on its own above the 

Layers panel group. 

A. Title bar B. Tab C. Drop zone 

Note: Press Ctrl (Windows) or Command (Mac OS) while moving a panel to 

prevent it from docking. Press Esc while moving the panel to cancel the operation. 



DEPARTMENT OF COMPUTER SCIENCE 
 

 

BCA-402 
Computer Graphics & Packages 

 

P
ag

e6
2

 

ADD AND REMOVE PANELS 

If you remove all panels from a dock, the dock disappears. You can create a 

dock by moving panels to the right edge of the workspace until a drop zone 

appears. 

 To remove a panel, right-click (Windows) or Control-click (Mac) its tab and 

then select Close, or deselect it from the Window menu. 

 To add a panel, select it from the Window menu and dock it wherever you 

want. 

MANIPULATE PANEL GROUPS 

 To move a panel into a group, drag the panel’s tab to the highlighted drop 

zone in the group. 

 

Adding a panel to a panel group 

 To rearrange panels in a group, drag a panel’s tab to a new location in the 

group. 

 To remove a panel from a group so that it floats freely, drag the panel by its 

tab outside the group. 

 To move a group, drag the title bar (the area above the tabs). 

STACK FLOATING PANELS 

When you drag a panel out of its dock but not into a drop zone, the panel 

floats freely. The floating panel allows you to position it anywhere in the 
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workspace. You can stack floating panels or panel groups so that they move as a 

unit when you drag the topmost title bar. 

 

Free-floating stacked panels 

 To stack floating panels, drag a panel by its tab to the drop zone at the 

bottom of another panel. 

 To change the stacking order, drag a panel up or down by its tab. 

Note: Be sure to release the tab over the narrow drop zone between panels, 

rather than the broad drop zone in a title bar. 

 To remove a panel or panel group from the stack, so that it floats by itself, 

drag it out by its tab or title bar. 

RESIZE PANELS 

 To minimize or maximize a panel, panel group, or stack of panels, double-

click a tab. You can also double-click the tab area (the empty space next to 

the tabs). 

 To resize a panel, drag any side of the panel. Some panels, such as the Color 

panel cannot be resized by dragging. 

COLLAPSE AND EXPAND PANEL ICONS 

You can collapse panels to icons to reduce clutter on the workspace. In some 

cases, panels are collapsed to icons in the default workspace. 

 To collapse or expand all panel icons in a column, click the double arrow at 

the top of the dock. 

 To expand a single panel icon, click it. 
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 To resize panel icons so that you see only the icons (and not the labels), 

adjust the width of the dock until the text disappears. To display the icon 

text again, make the dock wider. 

 To collapse an expanded panel back to its icon, click its tab, its icon, or the 

double arrow in the panel’s title bar. 

 To add a floating panel or panel group to an icon dock, drag it in by its tab 

or title bar. (Panels are automatically collapsed to icons when added to an 

icon dock.) 

 To move a panel icon (or panel icon group), drag the icon. You can drag 

panel icons up and down in the dock, into other docks (where they appear 

in the panel style of that dock), or outside the dock (where they appear as 

floating icons). 

PREVENT ACCIDENTAL PANEL MOVES WITH LOCK WORKSPACE 

Introduced in the October 2018 release of Photoshop CC (version 20.0) 

Use the Lock Workspace option to prevent accidentally moving workspace panels, 

particularly when you’re using Photoshop on a tablet/stylus. To access this option, 

choose Window > Workspace > Lock Workspace. 

CREATE DOCUMENTS 

When you create a document in Photoshop, instead of beginning with a 

blank canvas, you can choose from a wide variety of templates, including templates 

from Adobe Stock. Templates include stock assets and illustrations that you can 

build on to complete your project. When you open a template in Photoshop, you 

can work with it just as you would work with any other Photoshop document (.psd). 

In addition to templates, you can also create a document by selecting one of the 

numerous blank presets available in Photoshop. 

Save and switch workspaces 

By saving the current size and position of panels as a named workspace, you can 

restore that workspace even if you move or close a panel. The names of saved 

workspaces appear in the workspace switcher in the Application bar. 
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SAVE A CUSTOM WORKSPACE 

 With the workspace in the configuration you want to save, choose Window 

> Workspace > New Workspace. 

 Type a name for the workspace. 

 Under Capture, select one or more options: 

Keyboard shortcuts 

o Saves the current set of keyboard shortcuts (Photoshop only). 

o Menus or Menu Customization.   Saves the current set of menus. 

DISPLAY OR SWITCH WORKSPACES 

Select a workspace from the workspace switcher in the Application bar. 

Note: In Photoshop, you can assign keyboard shortcuts to each workspace to 

navigate among them quickly. 

DELETE A CUSTOM WORKSPACE 

Select Manage Workspaces from the workspace switcher in the Application bar, 

select the workspace, and then click Delete. 

 Select Delete Workspace from the workspace switcher. 

 Choose Window > Workspace > Delete Workspace, select the workspace, 

and then click Delete. 

RESTORE THE DEFAULT WORKSPACE 

Select the Default or Essentials workspace from the workspace switcher in 

the application bar. 

Select Window > Workspace > Reset [Workspace Name]. 

RESTORE A SAVED WORKSPACE ARRANGEMENT 

In Photoshop, workspaces automatically appear as you last arranged them, but 

you can restore the original, saved arrangement of panels. 

 To restore an individual workspace, choose Window > Workspace > Reset 

[Workspace Name]. 
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 To restore all the workspaces installed with Photoshop, click Restore Default 

Workspaces in the Interface preferences. 

Note: To rearrange the order of workspaces in the application bar, drag them. 

LAYERS 

Photoshop layers are like sheets of stacked acetate. We can also change the 

opacity of a layer to make content partially transparent. Transparent areas on a 

layer let you see layers below. You use layers to perform tasks such as compositing 

multiple images, adding text to an image, or adding vector graphic shapes. 

CHANNELS 

Photoshop uses channels to store color information about an image or to 

store selections. Photoshop creates color information channels automatically and 

all Photoshop images contain at least one channel. Bitmap-mode, grayscale, 

duotone, and indexed-color images are each single-channel modes. 

PATHS 

Paths are really useful. Once you've got the hang of using the Pen tool and 

the other path tools, you can create really complex freehand shapes such as 

symbols, drawings and icons. You can then turn these shapes into raster images at 

any resolution! Paths are also great for selecting irregular objects 

TOOLBOX 

The toolbox contains the main tools for working on images. Click any tool to 

select and use it. A small arrow next to a tool in the toolbox indicates that the tool 

also has additional options available. In Photoshop, click and hold your mouse on a 

tool to see its options. 

OPTION BAR 

The Options Bar is the horizontal bar that runs underneath the Menu Bar in 

Photoshop. You can turn it on and off through the Windows menu, so if you don't 

see it on your screen, you definitely want to turn it on with Window > Options. The 

job of the Options Bar is to set the options of the tool you are about to use. 
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OPEN 

If the file does not appear, select the option for showing all files from the 

Files Of Type (Windows) or Enable (Mac OS) pop-up menu. Click Open. In some 

cases, a dialog box appears, letting you set format-specific options. 

PLACE 

The Place command adds a photo, art, or any Photoshop-supported file as a 

Smart Object to your document. Smart Objects can be scaled, positioned, skewed, 

rotated, or warped without degrading the image. 

IMPORT 

In Photoshop, you can choose to open an image to work with or import 

content into a document that's open already. Choose File→ Place to import AI, EPS, 

PDP, or PDF files. These files import into a new layer in the document, and you can 

then use tools to manipulate the imported content 

SELECTION TOOL 

The most obvious selection tools in Photoshop are found in the toolbar which 

is located together with your brushes, pens, and cloning tools. 

1. Marquee 

The first one from the top of the toolbar is the Marquee tool. The Marquee 

tool is the most basic selection tool available in Photoshop. To use it, just click and 

drag around an area you want to select. 

You can choose between rectangular, circular, single line row or single column row 

marquee options by holding down the button and selecting your chosen marquee 

tool. 

2. Lasso 

Since the marquee tool is limited by a frame, circle, or line, it’s unavoidable 

to select more that what you actually want to select. To solve this problem, you can 

use the lasso tool. It works like the marquee tool except that it gives you the ability 

to move around areas freely without restriction. This allows you to avoid areas that 
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you don’t want to include. To do this, just click and drag the pointer around an area 

you want to select.  

A variation of this is the polygonal lasso tool which is a freehand selection tool that 

works similar to the pen tool but for selection purposes. The selection is restricted 

to polygonal outlines but is easier to use than the lasso tool because you don’t have 

to drag the pointer around. Instead, just click on different points along a path that 

you want to select. It allows you to select freely based on the points. 

3. Magnetic Lasso Tool 

The Magnetic Lasso Tool is a very useful outlining tool as it is more precise 

than the other lasso tools. It follows lines and outlines like a magnet which makes 

it easier to select elements with contours. 

Just click on the first point and move the pointer along the path or outline you wish 

to follow and finish the selection by going back to the original point. 

4. Magic Wand 

The magic wand is used to select an area based on a specific color. It is best 

used when selecting areas where color is varied but you want to select a specific 

color area. This makes selection faster when dealing with contours and sharp edges 

that are normally difficult to reach and takes time to select using the freehand 

tools. 

This tool is used by simply clicking on a certain color in a desired area you want to 

select. Magic Wand and Quick Selection share the same button space. Click and 

hold the icon to reveal the two options.  

5. Quick Selection 

The quick selection tool works similarly to the magic wand. It selects areas 

based on color and tone. Just click on an area you want to include in the selection 

and Photoshop will automatically determine the area you want selected. 

But the beauty of this tool lies in its ability to extend to other areas that you choose 

to include. You can choose to include or remove certain areas using the add to 
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selection and subtract a selection options in the tool options, respectively. It 

definitely makes selections quick and easy. 

Aside from the selection options in the toolbar, there is a section in the Photoshop 

menu that is fully dedicated to selection – the Select sub-menu. Sadly, not too many 

take time to check the tools there. In fact, the selection tools in there are quite 

useful when combined with other selection tools. Here are some: 

6. Color Range 

Hidden under the Select sub-menu is one of the most useful selection tools 

available in Photoshop – Color Range. Color range works similarly with the magic 

wand too. But instead of a limited selection based on a specific area, Color Range 

universally includes areas in the selection given a specific scope of colors you 

choose from within the image. 

Multiple color selection and limitation is also available by using the add and 

subtract eye dropper options. 

7. Inverse 

Accessible through the Select sub-menu, Inverse is used only with a pre-

existing selection. It automatically selects the area that isn’t selected initially and 

deselects the pre-existing selection, therefore inversing the process. If selecting an 

area is more difficult than selecting the areas around it, you can use inverse by 

selecting those areas outside and choosing to inverse the selection later. This 

makes the process faster. 

Just look at the example below. Because the background has an even tone 

compared to the subject, you can choose to select the subject using another tool 

first and then simply use the Inverse tool to select the subject. Ctrl + I is a quick 

keyboard shortcut that you can use to invert selection. 

8. Grow 

Again, accessible through the Select sub-menu, Grow is a selection option 

also used with a pre-existing selection. Grow simply extends the selection based on 

the current selection, usually based on color and tone. 
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The example below shows that the selection expanded to cover a wider area but 

still within the confines of its tone and color. It further expanded when you use to 

Grow tool one more time. You can repeat the process until your desired area is 

selected fully. 

9. Similar 

Similar is also accessible through the Select sub-menu, also works with a pre-

existing selection and is much like color range where it extends the selection to the 

whole image given the specific color and tonal range of the existing selection. 

Let’s say you've selected a patch of clouds in the sky, you can extend the selection 

to include the other clouds which would probably have the same color and tonal 

range using Similar. Take note however that it will also include areas in your frame 

that are of similar color and tonal range even if they aren't clouds. Like Grow, this 

process can be repeated as desired.   

10. Refine Edge 

When you need to be meticulous about the edges of a selection, you can use 

this tool to manipulate or customize the contours of the selection given in the 

Refine Edge options. 

It takes a lot of practice and a little getting used to before being able to fully 

understand using this tool but it is indeed helpful in making your selection more 

precise. Accessible through the Select sub-menu. 

New Tool – Object Selection Tool (Latest Version) 

Object Selection Tool was introduced in Photoshop CC 2020 and it can be 

found in the Select and Mask dialog. 

With this tool you can trace around any object you picked in two ways – using 

Rectangle or Lasso. Rectangle allows you to make a rectangular marquee while 

Lasso allows you to draw freehand. Object Selection Tool does a great job 

determining what you’re trying to select because of its impressive AI. 

This tool is like a Magic wand and Magnetic lasso mix, powered by Adobe’s 

prestigious AI engine called Sensei. To learn more about it, watch the video below: 



DEPARTMENT OF COMPUTER SCIENCE 
 

 

BCA-402 
Computer Graphics & Packages 

 

P
ag

e7
1

 

Tips and Tricks on Object Selection Tool 

These tools are simply the most convenient selection tools available in Photoshop. 

There are also other techniques available in Photoshop where you can maximize 

your selections for more effective image manipulation. 

Each tool and technique has its edge in terms of speed or its ability to be precise. 

Knowing what to use given your specific need will definitely be an advantage.   

CREATE AND SAVE SELECTION 

Make a selection using any of the selection tools or methods. To save this 

selection, choose Select > Save Selection. In the Save Selection dialog box, go to the 

Name field and give this selection a name. Click OK to close the Save Selection 

dialog box. 

MODIFYING SELECTIONS 

Remove stray pixels from a color-based selection. The Smooth command 

searches around each selected pixel for other pixels within the specified color range 

and selects them. Make a selection with a selection tool and choose Select > Modify 

> Smooth. For Sample Radius, enter a pixel value between 1 and 100, and click OK. 

PAINTING 

Adobe Photoshop provides several tools for painting and editing image color. 

The Brush tool and the Pencil tool work like traditional drawing tools applying color 

with brush strokes. Tools like the Eraser tool, Blur tool, and Smudge tool modify the 

existing colors in the image. 

FILTERS 

We can use filters to clean up or retouch our photos, apply special art effects 

that give our image the appearance of a sketch or impressionistic painting, or 

create unique transformations using distortions and lighting effects. The filters 

provided by Adobe appear in the Filter menu. 
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ADJUSTMENT LAYER 

The Adjustment Layers in Photoshop are a group of a super useful, non-

destructive image editing tools that add color and tonal adjustments to your image 

without permanently changing its pixels. With the adjustment layers, you can edit 

and discard your adjustments or restore your original image at any time. 

LAYER STYLE 

Select your desired layer in the Layers panel. Choose Layer→ Layer Style and 

choose an effect from the submenu. You can also click the Add a Layer Style icon in 

the Layers panel and select an effect from the drop-down menu. An intimidating 

Layer Style dialog box with a ton of options rears its head. 

 Drop Shadow. Adds a shadow that falls behind the contents on the layer. 

 Inner Shadow. Adds a shadow that falls just inside the edges of the layer's 

content, giving the layer a recessed appearance. 

 Outer Glow and Inner Glow.  

 Bevel and Emboss.  

 Satin.  

 Color, Gradient, and Pattern Overlay.  

 Stroke. 

RASTER 

In computer graphics, a raster graphics or bitmap image is a dot matrix data 

structure that represents a generally rectangular grid of pixels (points of color), 

viewable via a monitor, paper, or other display medium. Raster images are stored 

in image files with varying formats. 

VECTOR 

More specifically, a vector graphic is artwork made up of points, lines, and 

curves that are based upon mathematical equations, rather than a solid colored 

square pixels. This means that no matter how large or small or how close you zoom 

in on the image, the lines, curves, and points remain smooth. 
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DIFFERENCE BETWEEN VECTOR AND RASTER 

RASTER IMAGE FILE 

Raster images are constructed by a series of pixels, or individual blocks, to 

form an image. JPEG, GIF, and PNG are all raster image extensions. Every photo you 

find online or in print is a raster image. Pixels have a defined proportion based on 

their resolution (high or low), and when the pixels are stretched to fill space they 

were not originally intended to fit, they become distorted, resulting in blurry or 

unclear images. 

In order to retain pixel quality, you cannot resize raster images without 

compromising their resolution. As a result, it is important to remember to save 

raster files at the exact dimensions needed for the application. 

VECTOR IMAGE FILES 

Vector images are far more flexible. They are constructed using proportional 

formulas rather than pixels. EPS, AI and PDF are perfect for creating graphics that 

require frequent resizing. Your logo and brand graphics should have been created 

as a vector, and you should always have a master file on hand. The real beauty of 

vectors lies in their ability to be sized as small as a postage stamp, or large enough 

to fit on an 18-wheeler! 

If you're not sure whether you have a vector version of your logo, here's a little 

trick for you: Call the company that printed your business cards or the vendor that 

embroidered your logo on a shirt. Often they'll have a vector file of your logo that 

they can send to you for your records. 

HIGH RESOLUTION VS. LOW RESOLUTION 

Have you heard your designer talk about DPI or PPI? DPI stands for "dots per 

inch" and PPI translates to "pixels per inch." These units of measure are essential 

for determining if the density of pixels in an image is appropriate for the application 

you are using. 

The biggest thing to note when determining what DPI or PPI you require is if you 

are using an image for print or web. Websites display images at 72dpi, which is low 
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resolution; however images at this resolution look really crisp on the web. This is 

not the case for print. Best practices for printing an image will require it to be no 

less than 300dpi. 

Don't try to trick the system. A lot of magic can happen in Photoshop, but creating 

pixels out of thin air isn't one of them. Pulling an image off of the web and trying to 

get it to fit the dimensions of your print project just won't work. You will end up 

with a pixelated image that appears stretched and distorted. 

1. JPEG (or JPG) - Joint Photographic Experts Group 

2. PNG - Portable Network Graphics 

3. GIF - Graphics Interchange Format 

4. TIFF - Tagged Image File 

5. PSD - Photoshop Document 

6. PDF - Portable Document Format 

7. EPS - Encapsulated Postscript 

8. AI - Adobe Illustrator Document 

9. INDD - Adobe Indesign Document 

10. RAW - Raw Image Formats 

1. JPEG (or JPG) - Joint Photographic Experts Group 

JPEGs might be the most common file type you run across on the web, and 

more than likely the kind of image that is in your company's MS Word version of its 

letterhead. JPEGs are known for their "lossy" compression, meaning that the 

quality of the image decreases as the file size decreases. 

You can use JPEGs for projects on the web, in Microsoft Office documents, or for 

projects that require printing at a high resolution. Paying attention to the resolution 

and file size with JPEGs is essential in order to produce a nice looking project. 

2. PNG - Portable Network Graphics 

PNGs are amazing for interactive documents such as web pages, but are not 

suitable for print. While PNGs are "lossless," meaning you can edit them and not 

lose quality, they are still low resolution. 
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The reason PNGs are used in most web projects is that you can save your image 

with more colors on a transparent background. This makes for a much sharper, 

web-quality image. 

3. GIF - Graphics Interchange Format 

GIFs are most common in their animated form, which are all the rage on 

Tumblr pages and in banner ads. It seems like every other day we have a new 

Grumpy Cat or Honey Boo Boo animated GIF. In their more basic form, GIFs are 

formed from up to 256 colors in the RGB colorspace. Due to the limited number of 

colors, the file size is drastically reduced. 

This is a common file type for web projects where an image needs to load very 

quickly, as opposed to one that needs to retain a higher level of quality. 

4. TIFF - Tagged Image File 

A TIF is a large raster file that doesn't lose quality. This file type is known for 

using "lossless compression," meaning the original image data is maintained 

regardless of how often you might copy, re-save, or compress the original file. 

Despite TIFF images' ability to recover their quality after manipulation, you should 

avoid using this file type on the web -- it can take forever to load. TIFF files are also 

commonly used when saving photographs for print. 

5. PSD - Photoshop Document 

PSDs are files that are created and saved in Adobe Photoshop, the most 

popular graphics editing software ever. This type of file contains "layers" that make 

modifying the image much easier to handle. This is also the program that generates 

the raster file types mentioned above. 

The largest disadvantage to PSDs is that Photoshop works with raster images as 

opposed to vector images. 

6. PDF - Portable Document Format 

PDFs were invented by Adobe with the goal of capturing and reviewing rich 

information from any application, on any computer, with anyone, anywhere. I'd say 

they've been pretty successful so far. 
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If a designer saves your vector logo in PDF format, you can view it without any 

design editing software (as long as you have downloaded the free Acrobat Reader 

software), and they have the ability to use this file to make further manipulations. 

This is by far the best universal tool for sharing graphics. 

7. EPS - Encapsulated Postscript 

EPS is a file in vector format that has been designed to produce high-

resolution graphics for print. Almost any kind of design software can create an EPS. 

The EPS extension is more of a universal file type (much like the PDF) that can be 

used to open vector-based artwork in any design editor, not just the more common 

Adobe products. This safeguards file transfers to designers that are not yet utilizing 

Adobe products, but may be using Corel Draw or Quark. 

8. AI - Adobe Illustrator Document 

AI is, by far, the image format most preferred by designers and the most 

reliable type of file format for using images in all types of projects from web to 

print, etc. 

Adobe Illustrator is the industry standard for creating artwork from scratch and 

therefore more than likely the program in which your logo was originally rendered. 

Illustrator produces vector artwork, the easiest type of file to manipulate. It can 

also create all of the aforementioned file types. Pretty cool stuff! It is by far the best 

tool in any designer's arsenal. 

9. INDD - Adobe Indesign Document 

INDDs (Indesign Document) are files that are created and saved in Adobe 

Indesign. Indesign is commonly used to create larger publications, such as 

newspapers, magazines and eBooks. 

Files from both Adobe Photoshop and Illustrator can be combined in Indesign to 

produce content rich designs that feature advanced typography, embedded 

graphics, page content, formatting information and other sophisticated layout-

related options. 
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10. RAW - Raw Image Formats 

A RAW image is the least-processed image type on this list -- it's often the 

first format a picture inherits when it's created. When you snap a photo with your 

camera, it's saved immediately in a raw file format. Only when you upload your 

media to a new device and edit it using image software is it saved using one of the 

image extensions explained above. 

RAW images are valuable because they capture every element of a photo without 

processing and losing small visual details. Eventually, however, you'll want to 

package them into a raster or vector file type so they can be transferred and resized 

for various purposes. 

As you can see from the icons above, there are multiple raw image files in which 

you can create images -- many of them native to certain cameras (and there are 

still dozens more formats not shown above). Here's a brief description of those four 

raw files above: 

 CR2: This image extension stands for Canon RAW 2, and was created by 

Canon for photos taken using its own digital cameras. They're actually based 

on the TIFF file type, making them inherently high in quality. 

 CRW: This image extension was also created by Canon, preceding the 

existence of the CR2. 

 NEF: This image extension stands for Nikon Electric Format, and is a RAW file 

type created by (you guessed it) Nikon Cameras. These image files actually 

allow for extensive editing without changing file types, provided the editing 

takes place using a Nikon device or Nikon Photoshop plugin. 

 PEF: This image extension stands for Pentax Electronic Format, a RAW image 

file type created by Pentax Digital Cameras. 

ALPHA CHANNELS AND CLIPPING PATH 

Alpha channels are masks through which you can display images. The alpha 

channel is an 8-bit channel, which means it has 256 levels of gray from 0 (black) to 

255 (white). ... Alpha channels are usually used with 16.8M color RGB images. The 

resulting image is called RGBA (RGB+A, A means alpha channel). 
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Basically, tracing out a shape by pen tool in Photoshop is termed as applying 

clipping paths to that image which means to cut it from the background in order to 

use it in some other image. On the contrary, the alpha channel saves the selection 

like a grayscale mask which is editable. 

MASK 

There are two types of Adobe Photoshop layer masks, layer and vector. A 

layer mask also known as a pixel mask is a resolution dependent image created with 

the painting and selection tools, whilst a vector mask is a resolution independent 

object created with the pen or a shape tool that contains anchor points. 

QUICK MASK 

We generally use Quick Mask when working with a selection tool such as the 

Magnetic Lasso or Quick Selection tool. A Quick Mask temporarily turns the area 

inside our selection a semi-opaque red so that we can see what part of the image 

we have and have not selected. 

NOTE TOOL 

We can use the note tool to add text notes to a file in Photoshop. Documents 

that are annotated in this way can be saved in the Photoshop (PSD), PDF or TIFF 

formats. To annotate an open document, select the note tool, configure the Note 

settings in the Options bar. 

SAVE FOR WEB 

Save For Web is a nifty feature of later editions of Adobe Photoshop that 

allows us to compromise in a better way with size and quality in order to retain a 

decent looking JPEG, PNG or GIF. It does this by reducing the quality and stripping 

out unnecessary metadata. 

AUTO BLEND & AUTO ALIGN LAYERS 

Auto-Blend Layers applies layer masks as needed to each layer to mask out 

over or underexposed areas or content differences. Auto-Blend layers is available 

only for RGB or Grayscale images. It does not work with Smart Objects, video layers, 

3D layers, or background layers. 
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One of the coolest features in Photoshop CS6 is the Auto-Align Layers command. 

The Auto-Align Layers feature enables you to take these multiple images and 

composite them into that perfect shot by aligning your image and then letting you 

mask out the parts of the image that you don't want. 

3D COMMAND 

From opening a 3D file to rotating, scaling and moving it, working with 

meshes, creating textures or even materials, adding lights, and more. 

PIXELS & RESOLUTION 

Pixel is tiny component of any digital image, Resolution refers to the number 

of pixels in an image. Resolution is sometimes identified by the width and height of 

the image as well as the total number of pixels in the image. For example, an image 

that is 2048 pixels wide and 1536 pixels high (2048 x 1536) contains (multiply) 

3,145,728 pixels (or 3.1 Megapixels). 

IMAGE SIZE COMMAND 

Pixel dimensions measure the total number of pixels along an image's width 

and height. Resolution is the fineness of detail in a bitmap image and is measured 

in pixels per inch (ppi). In Photoshop, we can see the relationship between image 

size and resolution in the Image Size dialog box (choose Image > Image Size) 

INTERPOLATION OPTION 

When we upsample, we're adding pixels. Photoshop adds these pixels by 

using interpolation. Interpolation means Photoshop analyzes the colors of the 

original pixels and “manufactures” new ones, which are added to the existing ones. 

We can specify the interpolation method in the Image Size dialog box. 

CROPPING & STRAIGHTENING AN IMAGE 

Cropping is the process of removing portions of a photo to create focus or 

strengthen the composition. Use the Crop tool to crop and straighten photos in 

Photoshop. The Crop tool is non-destructive, and you can choose to retain the 

cropped pixels to optimize the crop boundaries later. 

 



DEPARTMENT OF COMPUTER SCIENCE 
 

 

BCA-402 
Computer Graphics & Packages 

 

P
ag

e8
0

 

 

WORKING WITH LAYERS AND EFFECTS 

Photoshop provides a variety of effects- such as shadows, glows, and bevels- 

that change the appearance of a layer’s contents in a non-destructive way. Layer 

effects are linked to the layer contents. When you move or edit the contents of the 

layer, the same effects are applied to the modified contents. For example, if you 

apply a drop shadow to a text layer and then add new text, the shadow is added 

automatically to the new text. 

A layer style is one or more effects applied to a layer or layer group. You can apply 

one of the preset styles provided with Photoshop or create a custom style using the 

Layer Style dialog box. The layer effects icon  appears to the right of the layer’s 

name in the Layers panel. You can expand the style in the Layers panel to view or 

edit the effects that compose the style. 

You can apply multiple effects in a single layer style. Also, more than one instance 

of some effects can comprise a layer style. 

 

Layers panel showing layer with multiple effects applied 

A. Layer effects icon B. Click to expand and show layer effects C. Layer effects 

When you save a custom style, it becomes a preset style. Preset styles appear in 

the Styles panel and can be applied to a layer or group with a single click. 
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APPLY PRESET STYLES 

You can apply preset styles from the Styles panel. The layer styles that come 

with Photoshop are grouped into libraries by function. For example, one library 

contains styles for creating web buttons; another library contains styles for adding 

effects to text. To access these styles, you need to load the appropriate library. For 

information on loading and saving styles, see Create and manage preset styles. 

Note: You cannot apply layer styles to a background, locked layer, or group. 

DISPLAY THE STYLES PANEL 

 Choose Window > Styles. 

APPLY A PRESET STYLE TO A LAYER 

Normally, applying a preset style replaces the current layer style. However, you can 

add the attributes of a second style to those of the current style. 

Do one of the following: 

 Click a style in the Styles panel to apply it to the currently selected layers. 

 Drag a style from the Styles panel onto a layer in the Layers panel. 

 Drag a style from the Styles panel to the document window, and release the 

mouse button when the pointer is over the layer content to which you want 

to apply the style. 

Note: Hold down Shift as you click or drag to add (rather than replace) the style to 

any existing effects on the destination layer. 

 Choose Layer > Layer Style > Blending Options, and click the word Styles in 

the Layer Style dialog box (top item in the list on the left side of the dialog 

box). Click the style you want to apply, and click OK. 

 When using a Shape tool or Pen tool in shape layers mode, select a style from 

the pop‑up panel in the options bar before drawing the shape. 

Note: Some effects have a + icon, indicating that they can be applied more than 

once in a layer style. 
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APPLY A STYLE FROM ANOTHER LAYER 

 In the Layers panel, Alt-drag (Windows) or Option-drag (Mac OS) the style 

from a layer’s effect list to copy it to another layer. 

 In the Layers panel, click-drag the style from a layer’s effect list to move it to 

another layer. 

CHANGE HOW PRESET STYLES ARE DISPLAYED 

 Click the triangle in the Styles panel, Layer Style dialog box, or Layer Style 

pop‑up panel in the options bar. 

 Choose a display option from the panel menu: 

 Text only to view the layer styles as a list. 

 Small Thumbnail or Large Thumbnail to view the layer styles as 

thumbnails. 

 Small List or Large List to view the layer styles as a list, with a thumbnail 

of the selected layer style displayed. 

You can create custom styles using one or more of the following effects: 

DROP SHADOW 

Adds a shadow that falls behind the contents on the layer. 

INNER SHADOW 

Adds a shadow that falls just inside the edges of the layer’s content, giving 

the layer a recessed appearance. 

OUTER GLOW AND INNER GLOW 

Add glows that emanate from the outside or inside edges of the layer’s 

content. 

BEVEL AND EMBOSS 

Add various combinations of highlights and shadows to a layer. 
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SATIN 

Applies interior shading that creates a satiny finish. 

COLOR, GRADIENT, AND PATTERN OVERLAY 

Fills the layer’s content with a color, gradient, or pattern. 

STROKE 

Outlines the object on the current layer using color, a gradient, or a pattern. 

It is particularly useful on hard-edged shapes such as type. 

BACKGROUND LAYER 

The background is the part of the image that is farthest from the viewer. 

Background layer (in Photoshop) The bottommost layer in the Layers palette, the 

background layer is always locked (protected), meaning you cannot change its 

stacking order, blending mode, or opacity (unless you convert it into a regular 

layer). 

INTRODUCTION TO BLENDING MODES 

Photoshop Blend modes is a way to blend pixels of two images with each 

other to get different types of effects. There are so many reasons for blend modes 

to be popular among the designers. There are 19 original Blending Modes are: 

Normal, Dissolve, Darken, Multiply, Color, Burn, Darker Color, Lighten Screen, Color 

Dodge, Lighter Color, Overlay, Soft Light, Hard Light, Difference, Exclusion, Hue, 

Saturation, Color, and Luminosity. 

OPACITY & FILL 

Photoshop's Opacity and Fill options in the Layers panel both control the 

transparency of a layer and often behave exactly the same. Both the Opacity and 

Fill options control a layer's transparency. That is, they control how much the 

currently selected layer allows other layers below it in the document to show 

through. 
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BRUSH TOOL 

The Brush tool is a basic painting tool. It works like a traditional drawing tool 

by applying the color using strokes. It's located in the standard Tool Bar and its 

default shortcut is the letter B 

COLORS & SWATCHES 

The Swatches panel lets you quickly select colors and gives you access to 

many other color options. By using the panel menu you can select from a multitude 

of different color schemes, such as Pantone or web-safe color sets. These color 

systems are converted to whatever color mode in which you're working. 

GRADIENTS 

The Gradient tool creates a gradual blend between multiple colors. You can 

choose from preset gradient fills or create your own. Note: You cannot use the 

Gradient tool with bitmap or indexed-color images. 

PEN TOOL 

The Pen Tool in Photoshop creates paths and shapes which can be duplicated 

and manipulated to create complex selections, masks and objects. Unlike the Brush 

Tool and Pencil Tools, which “draw” pixels onto your image, the Pen Tool always 

creates a vector path when used. 

TYPE TOOL 

Adobe Photoshop is mostly used for illustrations and editing photographs. You 

can also add text in Photoshop and adjust qualities such as the font, size and color 

of the text, creating advertisements, images, or titles. Keep in mind that the main 

reason why people create text in Photoshop is to add a visual element to their 

Photoshop image with short messages, rather than type out long paragraphs or 

make text-only documents. 
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1. Select the Type tool from the tools palette. It looks like a "T." Click on the 

icon, or simply press "T" on your keyboard to bring up the text tool. Now, 

anywhere you click in your image will allow you to start adding type. 

2. Set your text settings using the menu at the top of the screen. Once you click 

the Text tool, a bunch of options will appear at the top of Photoshop allowing 

you to choose the color, font, size, and alignment. You can also use the 

"Character," or the "Paragraph," which resemble the text editing boxes in 

programs like Microsoft Word. You can find these boxes by clicking on 

"Window" from the very top of your screen and checking "Character" and 

"Paragraph." 

 Font: Lets you select different font names such as Arial and Times New 

Roman. 

 Font Size: Adjust the points of the font size to make the text bigger or 

smaller. 

 Font Alignment: Choose whether you want the text to be centered or 

flushed to the right or left. 

 Font Color: Clicking on the font color box will allow you to choose 

different colors for the text. 

3. Click on the part of your image where you want to add text in Photoshop. If 

you simply click somewhere on the image, a cursor will appear where your 

first letter will appear. You can simply start typing, and Photoshop will add 

the words from this starting point. 

 If you're just adding simple text, this may be all you need to do. 

 If you know how to use the pen tool, you can click on a path to write 

text along that line. 

4. Click and drag with the text tool, before typing, to contain the text to one 

area. If you need to text to fit with a specific area, you can click and drag out 

the area before you begin typing. Any text that doesn't fit will not appear 

unless you shrink the font size. 

5. Click outside the text box or press the Ctrl (Control) and Enter keys on your 

keyboard simultaneously to see how the text finally appears on your 
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Photoshop image. If it keeps trying to start new text when you click out, then 

simply click on another tool to leave the text editor and move on. You can 

double-click on the text, or simply click on it again with the Text tool selected 

to edit the font and type at any point. 

 You can no longer edit text if you "Rasterize it." If you accidentally get 

this option, ignore it for now. 

 If the text layer is selected, press Ctrl-T or Cmd-T to resize the text by 

hand, instead of having to choose new font sizes. 

6. Click and hold the Text icon in the toolbar for different text-writing options. 

Remember, this icon looks like a "T." Click on the T and hold the mouse down 

to reveal the following alternate text options. 

 Horizontal Type Tool: Used most frequently, the horizontal type tool 

lets you type solid letters horizontally from left to right. This is the one 

use if just normally click the Text tool. 

 Vertical Type Tool: Allows you to write your words up and down, 

instead of left to right. 

 Horizontal Type Mask Tool: This turns your text into a mask, which 

can be used for a variety of fun Photoshop tricks. Off the bat, it will 

basically map the layer beneath the text and use it to "color in" your 

type. 

 Vertical Type Mask Tool: Works just like the Horizontal Type Mask, 

but writes letters up and down instead of left to right. 

7. Use the "Paragraph" and "Character" menus to change line spacing, kerning, 

and more in-depth options. If you need complete control over your text, the 

Character and Paragraph menus are the place to go. The Character menu's 

logo is an A followed by a vertical line. Paragraph resembles a P with a double 

vertical line and circle filled in, but you can also click "Window → "Paragraph" 

if you can't see it. 

 Click and drag the icons in each menu to test them. You can actually 

seem them function in real time. Most deal with line spacing. 
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 The Character menu generally has more to do with the actual type, 

where Paragraph adjusts the overall block of text and it's alignment. 

 If you can't access the Paragraph Options, right-click the text and 

select "Convert to Paragraph Text. 

8. Right-Click on the text and choose "Blending Options" to bring up a variety 

effects for professional looking type. The Blending Options allow you to add 

shadows, outlines, glows, and even 3D options, each of which is fully 

customizable. While you should experiment freely in the Blending Options 

menu, some key effects for good text include: 

 Bevel & Emboss: This will make the text 3D. It reassembles turning 

the lines of the text into 3D cylinders, like pipes. 

 Stroke: This outlines your text with the line of a color, thickness, and 

texture you get to choose. 

 The Overlays: These will change the color of your font, placing a 

gradient, pattern, or new color over the shape of the text. You can 

even lower the opacities of these overlays, allowing you to do some 

fun shading and blending. 

 Drop Shadow: Puts a moveable, short shadow behind your text -- like 

there was a wall a foot or two behind it. You can change the angle, 

softness, and size of the shadow. 

9. Find and add free new fonts online. Adding fonts to a Photoshop is incredibly 

easy. You simply download the fonts, then drag them into the program to 

link them up. You can search online for "Free Fonts" to find anything you 

need. 

 Fonts are typically .ttf files. 

 

RETOUCHING TOOL 

Retouching skin is about making a bunch of small changes while preserving 

the more important details that make your subject unique. With those settings 

selected, create a new layer and then use the Spot Healing Brush Tool to paint over 

any hairs, lines, or small blemishes on the skin. 
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The retouching tools in Adobe Photoshop are: Clone Stamp, Pattern Stamp, Healing 

Brush, Patch and Color Replacement. 

These tools repair damaged images, apply repeated patterns, or replace colors in 

an image. 

If two or more tools occupy the same cell (the icon for the tool last used is always 

shown), in order to choose another tool, right-click the mouse on the arrow next 

to the icon and and choose another tool from the menu that appears. This menu 

will also appear if you click on the icon and press it for some time. 

1 - THE CLONE STAMP TOOL AND HEALING BRUSH CLONE 

The Clone Stamp tool and Healing Brush clone (copy) pixels from one part of an 

image to another, to another layer or even to another image. The difference 

between the Healing Brush and the Clone Stamp tool is, the Healing Brush in 

Photoshop takes into account the texture, illumination and shadows of the 

processed image. As a result, the fragment processed by the Healing Brush blends 

more easily into the rest of the image. 

To clone an area with the Clone Stamp or Healing Brush, follow these steps: 

 Step 1. Choose the tool from the Toolbar. 

 Step 2. Set the parameters for the tool in the Options panel: size, blending 

mode, the amount of opacity and others. 

 Step 3. Check Use All Layers, if you need to work with several layers at once. 

 Step 4. Check Aligned to create one clone selected from the area around a 

starting point. The mouse button can be released and new fragments 

selected. Also, the mode and size of the tool can be changed. If Align is 

unchecked, then each application of the tool will create a clone from the 

same starting point. 

 Step 5. Set a starting point. Do this by holding ALT, and then left-clicking on 

the point from which the clone will be taken. 

 Step 6. Move the cursor to the location where you want to copy the 

fragment. 
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 Step 7. Press the left mouse button and the clone will be applied. If the 

Healing Brush is used, then the cloned fragments, texture, luminance, and 

shadows, will be processed in relation to the pixels of the background image. 

2- PATCH TOOL 

The Patch tool repairs an area with pixels copied from another area or image. 

Like the Healing Brush, the Patch takes into account the texture, luminance, and 

shadows of the background image. 

This tool can be used in one of two ways: 

Define the place where the clone will be applied, then drag the tool to the source 

point. 

Follow these steps: 

 Step 1. Choose the Patch tool from the Toolbar. 

 Step 2. Choose the shape and size of the tool in the Options panel, and select 

Source in Patch's options. 

 Step 3. Draw a line with the Patch tool around the part of the image that 

needs to be restored. 

 Step 4. Drag the selected area to a new spot, from which the clone will be 

created. 

Define the source, then drag the tool to the damaged area. 

Follow these steps: 

 Step 1. Choose the Patch tool from the Toolbar. 

 Step 2. Choose the tool's size and shape in the Options panel, and in Patch's 

options select Destination. 

 Step 3. Draw a line with the Patch tool around the part of the image that will 

be cloned. 

 Step 4. Drag this area over the part of the image that needs repair. 
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3- PATTERN STAMP TOOL 

The Pattern Stamp tool works by drawing with a repeating pattern. This tool 

can be used to created a frame or design for wallpaper or for retouching the texture 

of part of an image. A pattern is selected from the Pattern Palette in the Options 

Panel. 

To use this tool, follow these steps: 

 Step 1. Choose the tool from the Toolbar. 

 Step 2. Set a pattern, by choosing it from the Pattern Palette in the Options 

Panel. 

 Step 3. Choose the size and shape, blending mode, amount of pattern opacity 

and other parameters for the tool in the Options Panel. 

 Step 4. Press the left mouse button and drag the tool into the image. 

A repeating pattern can also be used with the Healing Brush and Patch tool. To 

do this with the Healing Brush, in the tool's options select Pattern for the Source 

and choose a pattern from the Pattern Palette. To do this with the Patch tool - begin 

by using the tool to draw a line around an area (or use a previously selected area), 

then choose a pattern from the Pattern Palette and press the Use Pattern button. 

4- COLOR REPLACEMENT TOOL 

The Color Replacement tool replaces one color in an image with another. 

This tool can be used, for example, to repair the "red eye" effect. 

Follow these steps to use the tool: 

 Step 1. Choose the tool from the Toolbar. 

 Step 2. Set the color which will be used to replace the intended color in the 

image. 

 Step 3. Set the parameters for the tool in the Options Panel, such as: size and 

shape of the brush, the color's blend mode, color choice mode, opacity, etc. 

 Step 4. Click on the color in the image to be replaced. 
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RED EYE TOOL 

The light of the flash reflects from the retina and the camera captures this 

which results in the red color in the eyes. Photoshop allows us to remove this red-

eye using its features. A red-eye tool is a user-friendly tool which allows us to 

remove the red-eye effects appears in photographs. 

EXPORTING DOCUMENT/ SAVE AS 

Photoshop gives you so many ways to save files. How do you deliver your 

work in the most effective and efficient way? 

The options for saving and exporting files in Photoshop represent almost three 

decades of changing requirements, so there’s some duplication that can be 

confusing. Let’s untangle the options based on the requirements of your jobs. 

Do You Need to Preserve Layers? 

If you must preserve Photoshop layers in a file you’re delivering, choose File 

> Save As, and choose Photoshop from the Format pop-up menu. Preserving layers 

maintains the ability to edit the components of a Photoshop document, such as an 

adjustment layer, the characters in a text layer, or the effects applied to a layer. 

This is also important for applications that can manipulate Photoshop layers. For 

example, you can use Adobe InDesign to control which layers of a Photoshop 

document are visible in a page layout, and you can use Adobe After Effects to 

animate Photoshop layers independently in a video composition. 

Even though the TIFF and Photoshop PDF formats can also preserve layers and 

Photoshop features, applications that can manipulate Photoshop layers can usually 

require a document in Photoshop format. 

Is the Document Going to a Press? 

If you’re preparing your Photoshop document for a press, you’ll probably 

find the format you need in the Save As dialog box. The Format pop-up menu in the 

Save As dialog provides the Photoshop and TIFF file formats commonly used for 
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prepress, along with the less commonly used Photoshop EPS and Photoshop DCS 

file formats. 

The Photoshop PDF format in the Save As dialog provides PDF/X presets that you 

can select if you need to make a Photoshop document comply with a PDF/X 

standard. 

Is the Document for a Web Page or Mobile Device? 

Many users learn only one or two of the many ways to get web and mobile 

graphics out of Photoshop. Knowing the full range of options can help you solve 

more web graphics challenges. 

Comparing Export As and Save for Web (Legacy) 

Adobe recommends the Export As dialog box (choose File > Export As) as the 

first option for most web graphics. You can use Export As to create a copy of a 

Photoshop document in the PNG, JPEG, GIF, or SVG format. 

Export As dialog box 

Export As is the newer way to save web graphics from Photoshop. 

Long-time Photoshop users may be more familiar with the dialog box now called 

Save for Web (Legacy) (choose File > Export > Save for Web (Legacy)). 

Save for Web (Legacy) dialog box 

Save for Web (Legacy) is the older way to save web graphics, but it’s still useful. 

Export As and Save for Web (Legacy) have a lot in common. Export As is built on 

newer code that can handle larger documents. It can export multiple resolutions if 

you need to provide a web developer with standard and HiDPI/Retina device 

resolutions (for example, 1x, 2x, and 3x scale factors). But Save for Web (Legacy) 

gives you more control over compression, previewing, and metadata. And Save for 

Web (Legacy) can export a Photoshop video timeline as an animated GIF file. 
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The Quick Export command (select layers and choose File > Export > Quick Export) 

is like an express version of the Export As command, because you don’t have to 

stop at a dialog box each time you use it. Instead, you set up Quick Export by 

choosing File > Export > Export Preferences. When you choose Quick Export, it 

instantly exports using the preferences you set. Quick Export is great when you 

repeatedly export using the same settings. 

Understanding the Two Kinds of Export As 

Export As is also available on the Layer menu, and it’s different than Export As on 

the File menu. The key to telling the difference is where each command is available: 

Choose File > Export > Export As to save a copy of the entire document as a single 

file. 

Choose Layer > Export As to save selected layers or layer groups as separate files. 

It’s common to design Web and mobile graphics with buttons, images, and other 

components on their own layers, so Web/mobile developers may request those 

layers as separate files. Quick Export is also available on the Layer menu for 

exporting selected layers or layer groups. 

The Layer > Export As command is also available on the Layers panel menu. 

Automating Web Export with Generator 

If you’re a Web or app developer or working closely with one, you can automate 

the export of web graphics from Photoshop layers using Generator. How you name 

layer groups and layers determines how those layers export. For example, if you 

named a layer… 

728 x 90 banner.jpg 80% 

It will export as a 728 x 90 px file, named banner.jpg, in JPEG format, at a quality 

level of 80%. 

Where Generator saves time is that you never have to select layers or manually 

export them. Each time you edit the document, all layers and layer groups named 
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using Generator syntax will automatically export. That way, exports are always up 

to date. 

Generator syntax is powerful. For example, if you name a layer or layer group 

100 x 100 logo1.png, 200 x 200 logo2.png, 300 x 300 logo3.png 

Generator will export three files at different sizes. 

Layer group named to export multiple files through Generator 

The highlighted layer group is named so that it will export three files using 

Generator. 

If you want to use Generator, open the Photoshop Preferences dialog box, and in 

the Plug-ins panel, make sure Enable Generator is selected. Then choose File > 

Generate > Image Assets and make sure that command is enabled. For details 

about usage and syntax, see the Adobe help topic Generate Image Assets from 

Layers. 

GIF and JPEG Options You Might Not Need 

You may see the following Photoshop commands that sound like ways to 

export Web graphics, but they’re older or have specialized uses today: 

(Save As) CompuServe GIF. Another way to export as GIF is choosing File > Save As 

and choosing CompuServe GIF from the Format pop-up menu. But this is an older 

method that you might never need to use if the options in the Export As or Save for 

Web (Legacy) dialog boxes cover your requirements. 

(Save As) JPEG. The JPEG format option in the Save As dialog box can be useful 

when you want to save a JPEG format file intended only for print, or that won’t be 

uploaded to a Web page. The JPEG option in the Save As dialog box generally 

creates larger file sizes than the JPEG option in the Export As or Save for Web 

(Legacy) dialog boxes, because the Save As version includes more metadata such 

as resolution (ppi). 
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Zoomify. If you shop online, you’ve seen similar techniques: Zoomify lets you 

magnify an image within a rectangle of a specific size, so that enlarging it doesn’t 

take over the entire web page. This requires not just an image, but accompanying 

HTML code. That’s fine if you’re coding your own web page. However, Zoomify may 

not be practical if you’re posting an image through social media or on a template-

based web site builder. 

Do you need a PDF file? 

You might be surprised at how many ways you can convert a Photoshop 

document into a PDF file. To create: 

A one-page PDF file. Choose File > Save As, and choose Photoshop PDF. When you 

click the Save button, the Save Adobe PDF dialog box appears. You can choose from 

the same Adobe PDF Presets that other Adobe applications use. 

Photoshop PDF dialog box 

Selecting Photoshop PDF format opens the Save Adobe PDF dialog box also 

found in other Adobe applications. 

Artboards in a multiple-page PDF file. Choose File > Export > Artboards to PDF, so 

that anyone can review artboards you created, such as a web site design. 

Layer comps in a multiple-page PDF file. Choose File > Export > Layer Comps to PDF, 

so that anyone can review document variations you created using the Layer Comps 

panel. 

A slide show of multiple images. Choose File > Automate > PDF Presentation to 

create a multiple-page PDF file from files you select. You can then choose from 

Multi-Page Document, or Presentation (a self-running, full screen slide show when 

opened in Acrobat). 

PRINTING OPTIONS: Printing a file means sending the image to an inkjet printer. 

Photoshop can send your image to a variety of devices to be printed directly onto 

paper or converted to a positive or negative image on film. 


